1. DXCyborg's Avatar
    So yeah, as the title says, my touch screen isn't working anymore. However not the whole screen, just the middle lower part of it.

    It happened 2 days ago then when I did a battery pull it worked again. When it happened yesterday though, the battery pull didn't work and it's still not working since yesterday.

    I'm on the 540/585 hybrid and it was working fine for about a week.
    I haven't even dropped the phone once so I have no idea what could be the problem.
    Thanks in advance.
    01-14-12 05:47 AM
  2. andreisb's Avatar
    i'm using 7.1.190 and that happened to me today, but a battery pull did the trick.
    01-14-12 06:03 AM
  3. DXCyborg's Avatar
    It's not anymore for me..
    01-14-12 06:15 AM
  4. TheCROW163's Avatar
    Can it be an OS glitch? Take out the battery and wait for a couple of minutes till all the current drains off fron the circuitry then fire it up... Maybe even try to start it without sim and memory card... if it doesn't work maybe you should try reloading the OS.... Only then you'll know for sure if it's hardware related. Hope this helps.
    01-14-12 08:36 AM
  5. robsteve's Avatar
    You might want to check if there is a touch screen test on the device analyzer app on the phone.
    01-14-12 09:14 AM
  6. DXCyborg's Avatar
    @TheCrow: I actually wanted to ask this here hoping someone had another solution than reloading the OS since I hate doing that :P

    @byul: It doesn't respond anywhere but for some reason it started working back again without me doing anything now. This is confusing.
    I just hope it doesn't happen again. I just bought the phone like 2 weeks ago and this is giving me bad impressions.
    01-14-12 12:14 PM