1. supraking's Avatar
    Hey all,

    This is a bit bizarre. I did a search and only found similar issues with the first-gen BlackBerry Storm.

    When I leave my 9900 sitting flat on a surface (table, glass, etc), and attempt to interact with it by touching, dragging, tapping, etc. my device barely registers the touches. At times a drag will work, but generally, nothing happens or it thinks I'm tapping when dragging, double-tapping when tapping, etc..

    Has anyone else experienced this type of issue? Tried with case on/off, no difference in results. Now, for some reason, it's working perfectly fine (30 seconds after it was having problems), which leads me to believe this may be a software issue. I'm running .400.

    Let me know your experiences, thanks!
    10-21-11 05:17 PM
  2. rpritch's Avatar
    I have the same issue.
    10-21-11 05:57 PM
  3. NickA's Avatar
    It's because it can't make an "electrical connection" from your finger to the screen. Surfaces like wood, glass and stone don't conduct electricity.

    Try this though just to make sure: when it's not responding, use a finger on your other hand and just touch and hold you finger anywhere on the phone. Then with your other hand see if the screen responds. It should if everything is ok.
    10-21-11 06:32 PM
  4. sg8330's Avatar
    It's because it can't make an "electrical connection" from your finger to the screen. Surfaces like wood, glass and stone don't conduct electricity.

    Try this though just to make sure: when it's not responding, use a finger on your other hand and just touch and hold you finger anywhere on the phone. Then with your other hand see if the screen responds. It should if everything is ok.
    that make zero sense.

    for one, it's the electrical current the touch display senses, not what can be conducted through the device.

    number two, i don't have the same issue with my 9900.
    10-21-11 07:08 PM
  5. frifred's Avatar
    I do not have this problem with my 9930. Works just fine when lying on the table.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-21-11 10:23 PM
  6. orzywife's Avatar
    I have the same problem. Quite aggravating.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-21-11 10:31 PM
  7. MikeFromCanada's Avatar
    It's because of the proximity sensor.

    Try this, when the phone is lying flat and seemingly unresponsive, place a finger over the sensor, and then try using the touchscreen with the finger covering it. Should work like a charm.

    It's just because the phone does not sense anything in front of it and thus the touchscreen becomes unresponsive.
    10-21-11 10:44 PM
  8. jefo13's Avatar
    I upped the sensitivity and it helped

    Posted from my CrackBerry at wapforums.crackberry.com
    10-22-11 02:50 AM
  9. And
    Same here. Strange...
    10-22-11 04:37 AM
  10. JBoen's Avatar
    Chrome bezel must be contacted in order to make it work, well it's just a solution. I hope new software version will fix it.
    10-22-11 04:47 AM
  11. tard44's Avatar
    ...I've never experienced this difficulty, running the stock OS still (w/ no problems) and using the Otterbox Defender. I've tried it on all different surfaces (not that doing so would make a difference, I suppose, as it's always in the case) so maybe it is a software problem rather than the phone itself? I know this isn't exactly helpful, just adding that it's obviously not happening on all 9900's...
    10-22-11 05:20 AM
  12. JBoen's Avatar
    Yeh, not everyone having this issue. My friend's 9900 works perfectly, dang!
    10-22-11 05:26 AM
  13. Terrigno's Avatar
    Just tried it and dont have this problem either.
    10-22-11 07:56 AM
  14. And
    no problems here neither, sensor sens is on 90% both.
    He's talking about the touchscreen, not the trackpad.
    10-26-11 08:54 AM
LINK TO POST COPIED TO CLIPBOARD