1. sching's Avatar
    aargh!

    got my 9900 yesterday to upgrade from my older bold. everything seemed fine but the phone is stuck in EDGE. tried a new 4g sim card, but still EDGE.

    everything else works just fine.

    spent 2 hours on the phone with ATT and RIM. completely useless.

    can anyone help??
    09-07-11 05:37 PM
  2. grover5's Avatar
    I have some bad news for you. The TMO bold supports TMO 3G bands not AT&T 3G bands. You're stuck with EDGE or WIFI.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-07-11 05:43 PM
  3. SwitchBeach's Avatar
    Yeah, unfortunately it's not "stuck" on EDGE because EDGE is as good as you are going to get on that device on AT&T.
    09-07-11 05:45 PM
  4. mister_turtle's Avatar
    as far as i know...

    T-Mobile branded 9900 has different radio frequencies than an ATT branded BB.
    This means you will be stuck on EDGE.
    You will need an ATT branded 9900 to get 4G.
    (or a Rogers branded 9900 I think)
    09-07-11 05:46 PM
  5. bllyrdrgz's Avatar
    I laughed so hard! i'm so sorry.

    Return the Bold!
    anguuusss likes this.
    09-07-11 05:50 PM
  6. sching's Avatar
    that sucks. will the ones from rogers work with att?
    09-07-11 05:56 PM
  7. Phill_UK's Avatar
    that sucks. will the ones from rogers work with att?
    It does... and they will
    09-07-11 06:02 PM
  8. jefo13's Avatar
    The art of reading, saves $

    Posted from my CrackBerry at wapforums.crackberry.com
    09-07-11 09:53 PM
LINK TO POST COPIED TO CLIPBOARD