1. BlackberryUser950's Avatar
    I just bought the new bold 9900 from rogers today and for about 3 hours, everything was working really great.. BEAUTIFUL interface, incredible keyboard... I let the battery die..! Later on, I charged it until it hit 100%...Took out the charger, everything was going good.. Went over to a family members house, and things just started to get BEZERK.... First, the touch screen stopped working all of a sudden.... I said ok, whatever. That is fine, maybe it is a little glitch. 10 mins later, I check my phone and it is a split screen! Everything is overlapping each other.. Ok, now things are getting weird. I put it down, I come back and the Blackberry is on a black screen, STUCK. I touch the keyboards and it makes the sound you make when your dialing a number.. Hmm??? So, of course. I've had over about 4 Blackberrys, they never break and I've never had a story to tell about Blackberry like this... I do a battery pull.... The battery pull, is stuck on a black screen? It doesn't have the loading with the Blackberry sign... I don't know what to do man, I am obviously going to have to go to the store tomorrow and get a new one but what a hassle, what a disappointment... Hoping to god right now, that if I let this battery die and charge it. Everything will get better

    If anyone has any suggestions, GREATLY appreciated!

    thanks much!
    08-27-11 12:34 AM
  2. Bla1ze's Avatar

    If anyone has any suggestions, GREATLY appreciated!
    Return it. Have Rogers exchange it for a new one. Not sure why you would even really question it, you solved your own problem in your post, lol.
    08-27-11 12:37 AM
  3. BlackberryUser950's Avatar
    Yeah but why did this have to happen? Kind of pathetic.
    08-27-11 12:41 AM
  4. cwDosman's Avatar
    The touchscreen problem happend to me yesterday. Pull the battery, take out the Simcard. Boot up without Sim. Batterypull and then startup with Sim inserted. Fix'd my touchscreenglitch and is working fine now.

    Sent from my BlackBerry 9900 using Tapatalk
    08-27-11 02:11 AM
  5. funnykindel's Avatar
    this is the strangest problem i have read for any BB? replacement is the ultimate solution but i was just wondering why it occured in the first place, after starting up fine?

    was it an apps that you installled?
    did you do a device switch with BBDM? if you did, did you do it the right way?
    08-27-11 02:17 AM
  6. Masahiro's Avatar
    Yeah but why did this have to happen? Kind of pathetic.
    Well, Rogers and mostly every other carrier has an exchange policy for a reason. These things happen with technology these days, especially with us demanding more and more and more out of what is, in terms of physical size, less and less.
    08-27-11 02:26 AM
  7. mobibiz's Avatar
    I'd say that this could also be an issue due to some application. Remove the SIM and the flash card and then boot up the device see if it works, also attempt the safe mode this looks like a software issue. If nothing works replace the phone.
    08-27-11 02:32 AM
  8. FBA's Avatar
    "Terrifying" indeed - imagine the horror...wow.
    08-27-11 10:02 AM
  9. diego.roscetti's Avatar
    "Terrifying" indeed - imagine the horror...wow.
    Loving the sarcasm!!!

    Posted from my CrackBerry at wapforums.crackberry.com
    08-27-11 10:11 AM
  10. FBA's Avatar
    Not what I'd usually say...but given the dramatic title...
    08-27-11 10:53 AM
  11. Gucci33's Avatar
    Lol I thought his phone caught fire!

    Posted from my CrackBerry at wapforums.crackberry.com
    08-27-11 11:21 AM
  12. Bold9930's Avatar
    Just Terrifying.
    OMG...

    Welcome nebiew...After 4 BB's...Hmmm.

    I guess the iPhone forum must be boring these days...What happened to this forum the last few days...It's clearly out of hand and pretty obvious what's going on here. I've never seen so such a jealous/desperate undertaking in my life.

    BTW: My 9930 is AWESOME!!!!!!!!!!! STill.
    Last edited by Bold9930; 08-27-11 at 11:33 AM.
    shadysprings likes this.
    08-27-11 11:31 AM
  13. mpatel1080's Avatar
    "Terrifying...sad"?!?!?! With a hurricane roaring up the eastern seaboard, the slaughter of innocent people in Libya, famine in east Africa, two wars, and all the other problems in the world; you are crying about a little problem with your cell phone. Grow up Dude!!!
    08-27-11 03:20 PM
  14. Sharke's Avatar
    Oh my actual god

    Posted from my CrackBerry at wapforums.crackberry.com
    08-27-11 03:29 PM
  15. joju58's Avatar
    Just Terrifying.
    OMG...

    Welcome nebiew...After 4 BB's...Hmmm.

    I guess the iPhone forum must be boring these days...What happened to this forum the last few days...It's clearly out of hand and pretty obvious what's going on here. I've never seen so such a jealous/desperate undertaking in my life.

    BTW: My 9930 is AWESOME!!!!!!!!!!! STill.
    +1 another newbie troll post
    your post is like "hey, you reading my mind"
    08-27-11 04:12 PM
  16. sheldonbk's Avatar
    I'd say that this could also be an issue due to some application. Remove the SIM and the flash card and then boot up the device see if it works, also attempt the safe mode this looks like a software issue. If nothing works replace the phone.
    If that's true and it is application related, then the next logical question is whether you used DM"s device switch wizard. I did and the wizard isn't supposed to install any apps that aren't compatible. Rogers seemed to rush the release and I wonder if RIM didn't update the list of apps not to install during this wizard.

    I had been running a prior version of App World 3 from the beta zone on my 9700 when I ran the wizard. My berry ran well for a number of hours until I had time to check out some apps. That's when my berry went ape. After a couple hrs of backup, wipe, install latest leak (as the Rogers official 261 wasn't available for some reason from RIM yet), install apps one at a time, restore backup and everything was ok.

    By installing apps one at a time, it became crystal clear that certain apps weren't compatible and they were promptly deleted.
    08-27-11 04:33 PM
  17. shadysprings's Avatar
    I just bought the new bold 9900 from rogers today and for about 3 hours, everything was working really great.. BEAUTIFUL interface, incredible keyboard... I let the battery die..! Later on, I charged it until it hit 100%...Took out the charger, everything was going good.. Went over to a family members house, and things just started to get BEZERK.... First, the touch screen stopped working all of a sudden.... I said ok, whatever. That is fine, maybe it is a little glitch. 10 mins later, I check my phone and it is a split screen! Everything is overlapping each other.. Ok, now things are getting weird. I put it down, I come back and the Blackberry is on a black screen, STUCK. I touch the keyboards and it makes the sound you make when your dialing a number.. Hmm??? So, of course. I've had over about 4 Blackberrys, they never break and I've never had a story to tell about Blackberry like this... I do a battery pull.... The battery pull, is stuck on a black screen? It doesn't have the loading with the Blackberry sign... I don't know what to do man, I am obviously going to have to go to the store tomorrow and get a new one but what a hassle, what a disappointment... Hoping to god right now, that if I let this battery die and charge it. Everything will get better

    If anyone has any suggestions, GREATLY appreciated!

    thanks much!
    Cool story bro.
    08-27-11 04:52 PM
LINK TO POST COPIED TO CLIPBOARD