1. spaghettihooha's Avatar
    Hi all.

    Just got my new Bold 9000 and wanted to use Satnav. Browsing this website seems to suggest most of you are fans of Telenav. I thought I'd give it a go but I'm having problems getting hold of it. Can someone tell me what I might be doing wrong?

    First off I go to App World and search for Telenav and it doesn't find anything. Why is this? Anyway, instead I google telenav, go to their website and I'm greeted with a selection of Apple, Android or Blacbbery for my download. I then click on Blackberry and it takes me to Appworld where I see the message "Telenav GPS Plus (for OS 6 and 7) Unavailable for this device" I can also see summary and reviews but nothing more.

    What am I doing wrong?

    Thanks in advance for any help.

    Tom
    10-30-11 01:29 PM
  2. Laura Knotek's Avatar
    What device do you have: 9900 or 9000?

    What country do you reside in, and what carrier do you have?
    10-30-11 01:37 PM
  3. spaghettihooha's Avatar
    Hi Laura.

    Sorry for the lack of info. It's my first post!!

    Bold 9900 on T Mobile. It looks like I've got OS 7 v7.0.0.353.

    Hope this helps. Thanks in advance.

    Tom
    10-30-11 01:46 PM
  4. spaghettihooha's Avatar
    Oh and I'm in the UK. England to be precise.

    Tom
    10-30-11 01:47 PM
  5. petaf's Avatar
    In the US on T Mobile, Telenav is only available through T Mobile's App Store, not through BlackBerry App world. Try your carrier's app store maybe?
    10-30-11 01:52 PM
  6. Laura Knotek's Avatar
    Hi Laura.

    Sorry for the lack of info. It's my first post!!

    Bold 9900 on T Mobile. It looks like I've got OS 7 v7.0.0.353.

    Hope this helps. Thanks in advance.

    Tom
    Hi Tom,

    Try here. It looks like they offer a 30-day free trial.

    Don't know if this will work. I posted before I saw you are in the UK. I thought you had T-Mobile USA.
    10-30-11 01:56 PM
  7. SwitchBeach's Avatar
    United States only in App World.

    You might try this link and see if it supports your device. http://www.tnclient.com
    10-30-11 02:46 PM
  8. spaghettihooha's Avatar
    Hi all.

    Thanks for all the replies so far.

    Thanks for the link Laura. My device doesn't seem to be on there. It only mentions the 9900 as a 4G. Mine is a 3G i'm pretty sure.

    I found another thread where someone else seems to have the same problem and solves it with both a 9900 and T Mobile. However I still can't get it to work.

    Firstly, it seems my device isn't officially supported yet. I am going to email Telenav and will post any response I get later on.

    The link from the other thread is here. TeleNav OTA

    When I download the software and install it it seems to go on ok. Then when I run it it asks me for my 10 digit phone number. I input my number leaving out the first zero so it is 10 digits. Presumably this is correct? Then it asks me if I want my first 30 days free or a day pass for $2.99. Whichever option I choose it just says "Sever connection failed. Please try again later." I have tried this several times and it is always the same.

    Any ideas?

    Thanks in advance. Tom
    10-30-11 02:58 PM
  9. Laura Knotek's Avatar
    I would suggest contacting your carrier and asking them if they offer the app for subscription. Perhaps they might even offer something different but similar.

    "4G" is just a marketing gimmick that T-Mobile USA and AT&T use. It is HSPA+, which is not 4G. True 4G is LTE, which T-Mobile USA is not even planning and AT&T has just started. The 9900 does not support LTE anyway.
    10-30-11 03:08 PM
LINK TO POST COPIED TO CLIPBOARD