1. bigbamboo's Avatar
    Hi.

    I'm trying to sync my calendar using the Desktop Software - which usually works just fine, and this morning I have an error message which reads: 'CRTranDB::GoToRecord : record with specified id not found'.

    I've changed sync patterns, going bot to and from the device and ticking the option to 'delete all on the 9900', but whichever way I choose, I can't get past the error - which means I can't sync. Which means I don't have an up-to-date calendar the moment I leave the house.

    Any ideas? Thank you, in advance...
    09-22-11 04:30 AM
  2. karthulovesyou's Avatar
    I'm having the same issue; it's impossible for me to sync my calendar entries. Did you happen to solve this, or does anyone else have any input?
    10-13-11 11:41 AM
  3. PaulM-D's Avatar
    Same error here and it happens after reading 5 records.
    10-17-11 12:41 PM
  4. buchoman's Avatar
    I encountered this same issue syncing between my blackberry and MS Outlook.

    When syncing my calendar entries, Desktop Manager goes through 14 records, and then I get the "record with specified id not found" error. My blackberry is a 9700 (running 6.0 Bundle 2921).

    I do not know what caused this issue. However, In order to resolve the problem, I proceeded as follows.

    1. In Desktop Manager under the "Device" menu, I selected "Delete Data".

    2. When prompted to select which data type(s) to delete, I selected "Calendar - All" and checked the box "Backup before deleting"

    3. After deleting the Calendar data from my device, I navigated to the "Organizer" menu, and hit the "Configure" button for the Calendar.

    4. Under "Sync Direction" I selected "One Way To Your Device Only".

    5. I then hit the Sync button, and the calendar on my blackberry was repopulated with my calendar entries from MS Outlook.

    ***

    While the above steps did get me "up and running" again, I did lose the more recent calendar entries that I had created on my device (specifically those that had not yet been synced to MS Outlook).
    remmy00 likes this.
    10-25-11 01:13 PM
  5. remmy00's Avatar
    @buchoman Thanks for the tip.

    It worked to some extent. In my case I am also syncing tasks and memos (along with calendar).

    It appears that the corruption was (also?) in the tasks or memos since when I deleted the data and tried to sync it generated the same error message.

    I then deleted task and memo, did a sync for each "part" and it worked fine.
    11-29-11 06:45 PM
  6. swenson19's Avatar
    I had the same problem right after I downloaded the updated BBerry desktop manager software. Maybe they need to fix a bug.

    I deleted Calendar, Contacts, and Memos (the 3 folders that I sync) and then everything re-synced fine.
    02-16-12 03:04 PM
LINK TO POST COPIED TO CLIPBOARD