1. arthursim's Avatar
    For years, Rogers hasn't allowed us lowly users to have access to the function in BBs to turn on SMS Delivery Reports...i.e. the little "D" next to a sent SMS so that you know that it's been delivered.

    For years, I've been taking my SIM out of the phone, turning it on, going to settings and magically the option was there waiting to be enabled. This workaround has worked on every BB that I've owned forever it seems.

    Not anymore, unfortunately, because you can't access any settings NOR any data on the phone without your SIM card in there. If you try, it will warn you that it's going to do a clean WIPE of your phone. This is a fantastic feature for those that are security conscious, but I'm not a happy camper.

    I know I might be in the minority, but has anyone been able to get around this "limitation"?
    08-18-11 05:06 PM
  2. jgaspar89's Avatar
    Does a checkmark when its sent
    08-18-11 05:07 PM
  3. arthursim's Avatar
    Does a checkmark when its sent
    Yes, but that's not a delivery report. It used to show a small D right above that checkmark and that would indicate that the network had received it.
    08-18-11 05:10 PM
  4. overhere's Avatar
    did you try going into Messages>Options>Text Messaging> checking any/all boxes near the bottom under the header Notifications. Been working for me since day one 9900.
    08-18-11 07:58 PM
  5. Striker317's Avatar
    Stick a "!" as the very first character of your reply and you'll get a delivery confirmation in the form of an sms.
    08-18-11 08:34 PM
  6. BB.David's Avatar
    The SMS delivery reports are set too "off" by default. Make sure you eneable it.
    08-18-11 08:36 PM
  7. EVOP's Avatar
    nope if u actually run ur trackpad over the message it says sent so and so minutes ago
    08-19-11 12:18 AM
  8. arthursim's Avatar
    Thanks for the replies guys....the options at the bottom of Options->Text Messaging seem to be related to MMS and not SMS. I didn't know about "!" being a way to force a delivery msg..I'm assuming that's part of the GSM spec somewhere.

    Notwithstanding all of the suggestions, the simple little "D" can't get back in OS7...
    08-22-11 03:00 PM
  9. arthursim's Avatar
    The SMS delivery reports are set too "off" by default. Make sure you eneable it.
    I'm wondering if what David is mentioning here is exactly what I'm talking about the option is being hidden by the Rogers SIM in my phone. I bet this option shows up for you in Messages->Options->Text Messaging in the top section where it's missing for us lowly Rogers clients.

    Can anyone confirm if it's missing with a Bell or Telus SIM installed?
    08-22-11 03:02 PM
  10. Jagaer's Avatar
    On a Bell BB9900 with a Bell SIM in: Text Messages -> Options

    Under SMS, I've got:
    - Delivery Report
    - Data Coding
    - Service Center
    - Disable Word Substitution
    - Leave Messages on SIM Card
    - Network to Send Over
    - Retries
    08-22-11 03:32 PM
  11. arthursim's Avatar
    On a Bell BB9900 with a Bell SIM in: Text Messages -> Options

    Under SMS, I've got:
    - Delivery Report
    - Data Coding
    - Service Center
    - Disable Word Substitution
    - Leave Messages on SIM Card
    - Network to Send Over
    - Retries
    I knew it...DAMN YOU ROGERS!! lol

    Ok, so the question remains...I was able to simply set that option with no SIM card present, but it seems as though that's impossible now. ugh
    08-22-11 03:38 PM
LINK TO POST COPIED TO CLIPBOARD