1. cmscritic's Avatar
    I traded a phone for a new condition Bold 9900. It's on Telus. All of a sudden, i'm getting random reboots constantly. I've tried 7.0.0.585 which it's on now and 7.1 leak and the same issues. I can barely use it it just all of a sudden goes poof and reboots. I've no idea what to do and am wondering if it's a battery issue or something? It seems odd because it doesn't appear to happen when plugged in (but I'm not 100% sure on this either).

    I've read a million posts on this issue. Since I have no carrier to return it to, would I be able to get warranty assistance from RIM since it's still within the year? Has anyone else had this issue and have suggestions?

    Thanks in advance and if I neglected to include some info, please let me know.
    01-11-12 11:08 PM
  2. cmscritic's Avatar
    Surely someone else has had the issue and figured out a solution. There can't be this many threads without some resolution can there? I don't understand how this phone can get a 9/10 rating on the review if this issue is that broad.
    01-12-12 11:42 AM
  3. robsteve's Avatar
    Try cleaning the battery contacts on both the phone and battery with a soft cloth. You may also want to make sure there isn't a problem with you sd card if you have one in it. You need to take the battery out before removing the SD card otherwise it will get jammed in the phone.

    Is the phone Telus branded? If it was distributed by them, they should be able to fix it for you, as the imei number will be in their system.
    Last edited by robsteve; 01-12-12 at 11:52 AM.
    01-12-12 11:49 AM
  4. cmscritic's Avatar
    Thanks for the reply robsteve, I will try that.
    01-12-12 11:57 AM
  5. xXxKratosxXx's Avatar
    I had this problem on my previous phone (Storm 2 9550). Turns out it was the battery causing it. I switched batteries and the problem went away. You might have got a faulty battery
    01-12-12 02:21 PM
  6. emirozmen's Avatar
    Its a battery problem, %99.
    01-12-12 02:33 PM
  7. cmscritic's Avatar
    I just spoke to my rep @ Telus and she advised that "yes, there are known issues with the BB9900 battery…" and that she will swap it for me. I'll keep everyone posted if it does end up resolved. I certainly hope so. I picked up this 9900 to pair with my PB instead of using my 9300.
    01-12-12 02:59 PM
  8. aazidane's Avatar
    dude, have you tried wiping your device with bbsak and reinstalling everything?
    01-12-12 05:02 PM
  9. cmscritic's Avatar
    Ok so here's an update. 1) I've received and replaced the battery, no change. 2) I've changed the sim card, no change. 3) I've used BBSAK and wiped and reloaded an OS, no change. In fact, I've tried 5 different version of os 7 including the leak with no change. This is definitely a hardware issue of some kind. Going to return it. I'm not sure I should get another one, i'm rather scared that this is a problem most 9900's face or will face..

    Sucks cause I was loving this phone.
    01-13-12 07:45 AM
  10. robsteve's Avatar
    Ok so here's an update. 1) I've received and replaced the battery, no change. 2) I've changed the sim card, no change. 3) I've used BBSAK and wiped and reloaded an OS, no change. In fact, I've tried 5 different version of os 7 including the leak with no change. This is definitely a hardware issue of some kind. Going to return it. I'm not sure I should get another one, i'm rather scared that this is a problem most 9900's face or will face..

    Sucks cause I was loving this phone.
    If Telus will replace it, you should just replace it and try the new phone. It may just be a dud you got from an early batch.
    01-13-12 01:53 PM
LINK TO POST COPIED TO CLIPBOARD