1. LangeFisch's Avatar
    I have a 9900. It's an unlocked phone from Virgin Mobile. I tried placing a Rogers SIM in the phone and it went dead almost instantly. JVM error 545.

    I wiped it and installed a new OS (v .474). It seemed to work but when the phone booted the mobile network wasn't on. The phone asked if I wanted to turn it on and I said yes but it tried without success. I then went into run a diagnostic test and that couldn't turn it on either. Before that I tried to turn it on just by checking the box and it would show a grey checkmark but then it would just disappear.

    Anyway, basically I tried everything. I tried all of this with the Virgin SIM with no success. I tried the Rogers SIM too, and nothing. I tried os .503. Nothing. I went back to the original Virgin OS...nothing.

    Any ideas or am I just stuck with a hardware failure that coincidentally coincided with me swapping SIM cards?
    11-13-11 12:23 AM
  2. dictoresno's Avatar
    was the phone powered on during the SIM swap somehow?

    i cant see a SIM swap causing a hardware error.
    11-13-11 03:23 AM
  3. LangeFisch's Avatar
    No, battery was out. I think it's just a strange coincidence.

    Wi-fi seems to be working fine, it's just the network connection.

    Also, not sure if this means anything, but the Rogers SIM I used was previously in my Torch, which went dead. Is it possible that the SIM card passed some sort of virus along?
    11-13-11 04:00 PM
  4. dictoresno's Avatar
    i doubt that. i dont think there are SIM card viruses.
    11-13-11 06:55 PM
  5. chocolatluvn1's Avatar
    I'm having a imilar problem only I have the 9930 for Verizon...does anyone have a clue how to fix this?

    Posted from my CrackBerry at wapforums.crackberry.com
    11-19-11 02:00 AM
LINK TO POST COPIED TO CLIPBOARD