Built for Business - Learn more about BlackBerry KEY2
  1. hamzab's Avatar
    Hi all,

    Transitioned to outlook.com for my email as I'm not a big fan of gmail anymore.

    I've noticed that email takes 10-15 minutes to arrive to my outlook.com email address but with my gmail address it's almost instant to about a minute.

    How can I make my outlook email arrive faster? Do I need to pay to upgrade the account? It's my understanding that even though
    it's an outlook.com email account it isn't an exchange account.

    Thanks
    02-19-14 01:09 PM
  2. Carl Estes's Avatar
    Hi all,

    Transitioned to outlook.com for my email as I'm not a big fan of gmail anymore.

    I've noticed that email takes 10-15 minutes to arrive to my outlook.com email address but with my gmail address it's almost instant to about a minute.

    How can I make my outlook email arrive faster? Do I need to pay to upgrade the account? It's my understanding that even though
    it's an outlook.com email account it isn't an exchange account.

    Thanks
    Try going into email/account settings and look for email push, and try to set it for a faster time.

    Mine on my Z30 is at every 15 minutes (default) but you can go down to 5 minutes I beleive.

    c
    02-19-14 01:44 PM
  3. hamzab's Avatar
    Try going into email/account settings and look for email push, and try to set it for a faster time.

    Mine on my Z30 is at every 15 minutes (default) but you can go down to 5 minutes I beleive.

    c
    I'm on a 9900 so I don't think I can manually adjust those settings, it only gives me options for sync, login info etc.
    02-19-14 01:46 PM
  4. flyingsolid's Avatar
    I have noticed that Outlook, as of late, has 4-6 minute delays on my OS6 device but it has never been more than that.

    many days later EDIT: 9930 receiving all emails instant. 9650 has delays.
    Last edited by mrskycar; 02-28-14 at 04:21 PM. Reason: late edit; device w/out problem added
    02-20-14 01:22 PM
  5. anischab's Avatar
    I noticed the delay too... Outlook til 20 min sometimes... Gmail not... OP, you noticed it right... I have no solution yet. I Subscribed to your thread. Cheers.

    Posted via my BlackBerry*Q10, Germany - SQN100-3, Running OS 10.2.1.537
    02-20-14 01:27 PM
  6. Jerry A's Avatar
    Outlook.com doesn't support IMAP-IDLE (eg push IMAP) so it will only retrieve every 15 minutes.

    A better option would be to manually setup and choose the MSN/Hotmail option. Which did support push email for the Inbox (folders not supported - BIS limitation).

    That's assuming Microsoft is still supporting BIS (it's been 1 year since I've used a BBOS device so things may have changed).

    Bonus: If it works then it'll also sync your contacts.

    Not so bonus: Meeting invitations don't work with this setup. Don't worry though, BlackBerry has been aware of this bug for 5 years and that a fix is pending. Of course they've been saying that for about 5 years.
    02-20-14 01:49 PM
  7. BitPusher2600's Avatar
    I don't use Gmail but I do use Outlook and I've never noticed any issues. I sent myself an email from a secondary address I have at live.com and it came thru in about 10 seconds. I wish I could help.
    02-23-14 10:30 AM
  8. hamzab's Avatar
    Outlook.com doesn't support IMAP-IDLE (eg push IMAP) so it will only retrieve every 15 minutes.

    A better option would be to manually setup and choose the MSN/Hotmail option. Which did support push email for the Inbox (folders not supported - BIS limitation).

    That's assuming Microsoft is still supporting BIS (it's been 1 year since I've used a BBOS device so things may have changed).

    Bonus: If it works then it'll also sync your contacts.

    Not so bonus: Meeting invitations don't work with this setup. Don't worry though, BlackBerry has been aware of this bug for 5 years and that a fix is pending. Of course they've been saying that for about 5 years.
    Thanks for your reply and sorry for the delay.

    I've tried that but the only options for msn/hotmail are hotmail, man and windows live. If I remove @hotmail.com and type in @outlook.com it just sets up as an "other" account.

    The weird thing was that before I reinstalled the OS on my BB, outlook email actually had the Msn/windows live/hotmail icon. Don't know how I did It then!

    Any other ideas? You seem to be on to something
    03-02-14 06:11 PM
  9. g-thing's Avatar
    I have the same issue, I have noticed that the hotmail icon on the folder isn't there anymore. I had some stuck emails on my hotmail account and couldn't delete them so I delete my hotmail account and then re added it and thats when the issues came up, any updates to BIS? or anything?
    03-07-14 09:46 PM
  10. Mohis's Avatar
    I have been having this issue for months upon months - delayed emails coming through.
    I have numerous emails from @hotmail and also @live

    Has anyone found a 'fix' yet?
    05-06-14 11:18 AM
  11. Frehley's Avatar
    I'm having this same issue also. It's so bad, up to 20 minute delay, that I have resorted to using gmail as my default email and have set the Outlook client to forward any messages to my gmail account.

    I sure wish that a fix could be found.
    05-06-14 05:03 PM
  12. itag's Avatar
    bump !

    Also having a delay with my hotmail account...

    Could this be related to the fact that my blackberry ID is my hotmail account ?
    06-09-14 05:01 AM
  13. NursingNinja's Avatar
    My solution was to forward the email to the BIS account.
    07-13-16 08:38 PM
  14. NursingNinja's Avatar
    i got outlook.com to work faster, if you enable POP the delay goes away.

    Sent from my BlackBerry 9930 using Tapatalk
    07-14-16 11:06 PM

Similar Threads

  1. Blackberry World shows wrong number of updates
    By medianemesis in forum BlackBerry Z10
    Replies: 5
    Last Post: 03-03-14, 11:16 AM
  2. Replies: 7
    Last Post: 02-21-14, 09:47 AM
  3. Leaked photos show off QWERTY BlackBerry 10 prototype
    By CrackBerry News in forum CrackBerry.com News Discussion
    Replies: 10
    Last Post: 02-20-14, 05:45 AM
  4. Good e-reader app is not wanting to open on my Q10.
    By mjwolf in forum General BlackBerry Discussion
    Replies: 1
    Last Post: 02-19-14, 04:24 PM
  5. Why BlackBerry maps unavailable in india :(
    By Vaibhav Pawar in forum BlackBerry 10 OS
    Replies: 3
    Last Post: 02-19-14, 12:10 PM
LINK TO POST COPIED TO CLIPBOARD