1. josedavidp10's Avatar
    So, i've been trying to fix my 9900 (red led blinking, doesn't start), no luck so far. Any news? I think i tryed everything in the forums but it doesn't work.

    I tryed to Follow the tutorial for nuked devices: On Loader, I pass thru almost all the stages, i connect it with no battery, quickly click on next, select what i want to install (.540 btw), it deletes all the old data, install the new os, but in the stage "Wait for the device Initialization" i always get the "Aplication Loader cannot connect...." message. Tryed to Retry with no battery, with battery, in diferent timing, unplug usb plug usb. Tryed with fully charged battery, low battery didnt work either. Tryed almost everything and every combination, timing. I've read in some forums that this could work (unplug / plug) but it doesnt work. After 1 Day of tryings and i can't go thru this stage. Some people said they fixed it this way, but no luck so far. Tryed the /nojvm didn't work.

    BBsak, BBHybrid Tools and others (tryed like 6) don't recognize the device. So i cannot make a wipe or re-install OS that way. BB Master Tools recognize it sometimes, but when it runs the loader, it turns to be very slow and cannot detect the device, no matter what i do.

    What i found out is that sometimes you can stop the rebooting loop. If i leave the device plugged with no battery, the bb9900 shows the screen with a battery with a X (no battery sign) no loop until the battery is plugged, and some times with the battery plugged and running loader or DM; it shows a battery (empty) with the charging sign, no loop, but still is not detected by the computer. This also happens when charging.

    Tryed to fix the 9900 in 4 different computers, XP, W7, Vista and Mac. Didn't Work.

    Tryed to install different OS. .540 .503 7.1 .590. etc. But didn't work either.

    Tryed with differen DM versions. Didn't Work.

    It seems the problem it has to do with the software, but about the battery code. Because i always get trouble after installing the new os, it removes the old and installes the new one without any trouble,but when the device is initializating, the loop starts again and the aplication loader doesnt have enough time to recognize the device. Every time, in every computer, with every os.

    Reading in forums, i've also found out this happens to all nuked 9900 (even those fixed).

    Is not the JVM 507 error, this is different, with different solution hopefully.

    Is there any news? Another way to fix a nuked 9900? Please help
    12-20-11 07:35 PM
  2. Phill_UK's Avatar
    Tried (sp)
    12-20-11 07:39 PM
  3. josedavidp10's Avatar
    Hahaha sorry, my english sucks
    12-20-11 07:41 PM
  4. Phill_UK's Avatar
    No worries

    Sorry to hear about your issues. Unfortunately it seems that you have tried everything possible.

    You don't have a simple nuked 9900... you have a brick

    Can you return the phone for exchange?
    12-20-11 07:45 PM
  5. FBA's Avatar
    True definition of a bricked BB.
    Time to exchange it.
    Some around here think that it can be brought back from this state, but it really can't. If you could bring it back, it wouldn't be bricked!
    I have a 9800 in this state and exchanged my fiancee's 9900 in the same state as yours, despite all intensive efforts to bring it back to life.
    12-20-11 07:55 PM
  6. josedavidp10's Avatar
    The thing is i can't exchange it , i don't have warranty in my country. So i think i will keep trying

    The only thing that keeps me trying, is the RIM announcement about the 9900 having this trouble because of the software. And they working on a fix. I just want to fix it before them hahaha. I really need my 9900 for work.
    12-20-11 08:14 PM
  7. netnomad's Avatar
    Same problem here with my 9860. And one rumor about 7.1 will unbricked the dead phone keep my hope!
    12-20-11 09:46 PM