1. Raekwon_'s Avatar
    Hi

    Just got my new 9900 yesterday and I updated it to .353. I was wondering if it was normal not to be able to hide the message "My number: unknown number" from the call screen?

    With all my other BB's (OS5 & OS6) I just had to uncheck the show my number option and it disappeared but with OS7 even when you do that the message is still present... Any ideas?

    Thanks
    Last edited by Raekwon_; 09-25-11 at 03:17 PM.
    09-25-11 03:14 PM
  2. Phill_UK's Avatar
    Ever since OS4 I have never been able to hide the 'My Number' from the call screen. The option you mentioned to uncheck 'show my number' is definitely a carrier feature, and if supported is to hide your number from the recipient when calling out, not to remove it from the call screen.

    If your 'My Number' is showing 'unknown number' rather than your actual cell number, then that's an easy fix... Options > Device > Advanced System Settings > SIM Card > Phone Numbers > (Menu) Edit SIM Phone Number

    Posted from my CrackBerry at wapforums.crackberry.com
    mssca likes this.
    09-25-11 03:51 PM
  3. mssca's Avatar
    Ever since OS4 I have never been able to hide the 'My Number' from the call screen. The option you mentioned to uncheck 'show my number' is definitely a carrier feature, and if supported is to hide your number from the recipient when calling out, not to remove it from the call screen.

    If your 'My Number' is showing 'unknown number' rather than your actual cell number, then that's an easy fix... Options > Device > Advanced System Settings > SIM Card > Phone Numbers > (Menu) Edit SIM Phone Number

    Posted from my CrackBerry at wapforums.crackberry.com
    How do you get to this? > Phone Numbers > (Menu) Edit SIM Phone Number....

    I also have my number as unknown number. I am with Telus. EDIT: THANK YOU. I got it... just have to enter MEPD on the SIM window and on the menu there is edit numbers. Thanks.
    Last edited by mss-ca; 09-25-11 at 04:28 PM.
    09-25-11 04:26 PM
  4. Raekwon_'s Avatar
    Thanks for your answer phill

    Problem is, in that menu, if I select edit phone number nothing happens, I can't type anything so I don't know what to do...

    But that weird that you never were able to hide your number, I did it with every single BB I had, maybe I'm the only one...
    09-26-11 03:53 AM
  5. Phill_UK's Avatar
    Thanks for your answer phill

    Problem is, in that menu, if I select edit phone number nothing happens, I can't type anything so I don't know what to do...

    But that weird that you never were able to hide your number, I did it with every single BB I had, maybe I'm the only one...
    Provided your SIM card security is Disabled, you should be able to scroll down and highlight the empty Line 1 space, press the Menu, select Edit SIM phone Number and manually input your cell number. Then just back out and save your settings.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-26-11 05:07 AM
  6. Raekwon_'s Avatar
    I disabled the security but it still doesn't work, when I press edit sim number nothing happens, the menu just disappears and I can't type anything... I guess this doesn't work with all sim cards...

    Now the question is, if it worked before, what's the point of the option "show my number" with OS7 if it doesn't (like OS6 or OS5) hide your number on the call screen?
    09-26-11 09:19 AM
  7. blackberry-unlocking710's Avatar
    Try to turn the radio off and edit it.
    09-26-11 11:56 AM
  8. Raekwon_'s Avatar
    Tried and it doesn't work either.

    But I think it's due to my carrier sim cards that don't allow this...
    09-26-11 02:08 PM
  9. Phill_UK's Avatar
    I disabled the security but it still doesn't work, when I press edit sim number nothing happens, the menu just disappears and I can't type anything... I guess this doesn't work with all sim cards...

    Now the question is, if it worked before, what's the point of the option "show my number" with OS7 if it doesn't (like OS6 or OS5) hide your number on the call screen?
    No idea why you're not able to edit your SIM number, but I owe you an apology...

    I was mixing up the 'show My Number' option with 'Restrict My Identity'.

    With 'show My Number' unchecked, it does remove your number from the top of the call screen when you press the left hand call button, but it does not remove it from the screen that comes up when you're actually in a call. That is the screen that I've never been able to hide my number on.

    Restrict My Identity is a carrier feature which hides your number when calling out, if your carrier supports it. Sorry about the confusion there.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-26-11 02:42 PM
  10. Raekwon_'s Avatar
    No problem phill, thanks anyway
    09-26-11 02:50 PM
LINK TO POST COPIED TO CLIPBOARD