1. Derkachenko's Avatar
    Just picked up my new Bold 9900 last night, was all working well, no problems. I bought an Ishieldz screen protector and applied it. Now my touch screen no longer works. I never got any of the solution in the phone I was very careful. Any suggestions to try before I take it back?


    EDIT:Just pulled out my MicroSD card, touch screen is now working. WTF! that's weird LOL!
    Last edited by Derkachenko; 10-09-11 at 01:43 PM.
    10-09-11 01:09 PM
  2. Sharma15's Avatar
    Did the screen protector require u to spray your phone with water? If so you may have some water damage.
    10-09-11 01:21 PM
  3. BrwnSuga3's Avatar
    Yeah I would guess it might be water damage too, gotta be careful when applying a screen protector on this phone, I usually apply mine but took it into a store and had them do it for me this time.
    10-09-11 01:28 PM
  4. Derkachenko's Avatar
    Nope it did not. checked all moisture stickers and theyre still white
    10-09-11 01:33 PM
  5. Derkachenko's Avatar
    Just pulled out my MicroSD card, touch screen is now working. WTF! that's weird LOL!
    10-09-11 01:42 PM
  6. aznxtamboy's Avatar
    My screen was not responsive for me one time and I just did a battery pull and it fixed the issue. Give that a shot and see if it works.
    10-09-11 01:49 PM
  7. albee 1's Avatar
    Poorly seated sd cards have disabled other bb's. Put it back in and make sure it is in all the way before locking it in. Glad to hear all is well.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-09-11 07:08 PM
  8. Derkachenko's Avatar
    Poorly seated sd cards have disabled other bb's. Put it back in and make sure it is in all the way before locking it in. Glad to hear all is well.

    Posted from my CrackBerry at wapforums.crackberry.com
    Thanks for the tip! now just need to figure out how to update to 440
    10-09-11 09:32 PM
  9. TheMarco's Avatar
    I had the same thing after I had a screen protector applied for me. I thought I was gonna have a stroke. I read somewhere (I forgot where, sorry) that pulling the battery AND the SIM card would fix it. And it did for me.

    Weirdest thing ever. Never had my screen quit working again after that one time.
    10-09-11 09:41 PM
  10. Kwwie's Avatar
    Haha, yeah, the exact same thing happened to me. I had a full body ghost armor installed onto my device a few days ago. When I put the battery back in and turned it on for the first time, the touch screen didn't work. I was freakin out for a bit, because I thought it was water damage; did a battery pull, restarted the phone and that fixed the problem. I'm not sure why this happens. May just be a coincidence.

    Side note, I dropped my 9900 on concrete just this morning lol... faillll
    10-10-11 05:41 PM
LINK TO POST COPIED TO CLIPBOARD