1. TrickyT's Avatar
    when i go into Manage Connections and click the All Off button the connections all turn off.

    However, straight away it then comes up with searching for network and restores the Mobile Network connection.

    Can anyone help?

    I have smart wifi installed but this happens if it is activated or deactivated.


    01-04-12 04:08 PM
  2. TrickyT's Avatar
    No replies then.

    Looks like I will have to try my luck with Orange Customer Services then!

    01-06-12 11:02 AM
  3. cooljatt18's Avatar
    try a battery pull and also upgrade your OS. looks like a software glitch.
    01-06-12 11:33 AM
  4. calicocat2010's Avatar
    I can definitely help you. I Had this Same exact problem 2 days ago and I had a chat with an AT&T representative yesterday online and I told him this: I have noticed that my 9900 connections turn on automatically again just after manually turning them off. I was running errands today and I noticed my WIFI kept turning on by itself when my WIFI monitor app is disabled. I turned off the Wifi once more and then a couple of minutes later, it's back on. I can't have this happening because it drains my battery.

    I have already came in twice already to replace this phone. I don't want to come in a third time, but I can't figure out why the connections keep turning on by itself. Just last night, I had turned off my data and so the mobile network surely did not have anything to connect to but it still turned on by itself after I had just manually turned it off.

    The representative told me to first: take out the battery and then wait for him to say:insert the battery and then wait for the homescreen.
    I did that.
    He then told me to go into Manage Connections then hit the - Network Connections option. After that he told me to click on the Mobile Network. Once inside there to hit the BB menu and then run the Diagnostics Test.
    After the Diagnostics Test he asked me, "What do you see from the Connect To Blackberry AND BlackBerry Pin-To Pin." I told him I see "Yes".
    He then proceeded to tell me to go into my Manage Connections and then Turn them Off again to see if That fixed the problem.
    I turned them off waited for a couple of minutes but THEN they came back on again.
    I told him I had installed WIFI Manager and WIFI Monitor. He said for me to Uninstall those and then check the Manage Connections again with clicking on ALL OFF.
    I uninstalled those two apps,restarted the device, and then selected the ALL Off option.
    Again couple of minutes later they came back ON again automatically.

    Finally he said: Kael: It appears the device handheld software is not functioning properly.

    Kael: The handheld software will need to be reloaded on the device.

    Kael: The steps on how to do this can be found at att.com/blackberryupdate. As well as thru E-mail.

    Kael: The process can take up to two hours to complete.

    Kael: There will be a section in the steps that will walk you thru backing up your device.

    Kael: If this does not fix the issue you can call us back at 800-331-0500 24/7 or I can have someone call you as soon as tomorrow.

    Me: So I will have to uninstall the OS I am using which is .503 because the other higher builds have the battery drop of 100-92% and then Re-install it?

    Kael: Yes.

    Kael: If you need additional assistance specific to your device, you can view our website at Business Center Support. We welcome your feedback; please take a moment to complete our Customer Satisfaction Survey. Thank you for your business and have a pleasant day.


    I unistalled the OS and then Reinstalled it.
    The Error is FIXED.

    So OP, try these steps and see if the problem still persists.

    Last edited by calicocat2010; 01-06-12 at 12:58 PM.
    01-06-12 12:54 PM
  5. TrickyT's Avatar
    thanks for your replies.

    i am running the latest os from my carrier, Orange, and have tried a battery pull, but this has made no difference.

    i might try reinstaling the os but not that worried at the moment. Will live with it for now.


    01-07-12 04:16 PM
  6. emirozmen's Avatar
    Try reinstalling, that should work
    01-07-12 04:23 PM
  7. shrewsburysq's Avatar
    I think you will find that Smart WiFi is causing the problem. Try uninstalling that and see if that works. You can always reinstall Smart WiFi.
    01-07-12 06:42 PM
  8. Rootbrian's Avatar
    I don't use any apps to manage my connections, I just turn 'em off when not using any. Mobile network stays on unless I use the video app to prevent a call from interrupting the recording. I haven't encountered that issue yet, if I do, i'll take action.
    01-07-12 11:31 PM