Built for Business - Learn more about BlackBerry KEY2
  1. BB18244's Avatar
    Greetings!
    This morning I downloaded Logicmail from their website and got it setup, following the instructions of a Youtube video on how to use it on Wifi only. Sending emails was not a problem at all! I sent a test email to my dad's Z30 and he got it fairly quickly. Though he told me he had replied, I cannot seem to receive emails. When I load my inbox it says that there is nothing there. Does anyone know how to fix this? It would be greatly appreciated!

    I am using LogicMail on wifi because I do not have BIS. When i went to the store they had no idea what i was talking about! Lol.
    Thanks again,
    Cheers!

    Be Bold. Blackberry 9900.
    06-10-16 09:27 AM
  2. Michniks's Avatar
    Logic mail works also on normal data plan. Not only WiFi.

    Posted via CB10
    06-10-16 03:10 PM
  3. idssteve's Avatar
    When I load my inbox it says that there is nothing there. Does anyone know how to fix this?
    Are you using pop account?
    06-10-16 10:49 PM
  4. BB18244's Avatar
    Are you using pop account?
    yes

    Be Bold. Blackberry 9900.
    06-11-16 05:49 AM
  5. idssteve's Avatar
    Ok, RU getting any messages? Like asking to verify account password? Be sure to erase the stars & re-enter pw if it asks. My pop account required entering the full "pop.XXXX.com" server name. Also the full email address. Also had to set. "Use secure connection" to "TLS, if available". Yours might be different on some of that. If it's not happy with password or security settings it seems to provide a nag of some kind.

    Also, It won't update unless you've set it to refresh. I have mine set to refresh on startup and set refresh frequency to 5 min. if you're not seeing activity, might exit program & start again to force refresh. ??
    06-11-16 07:00 AM
  6. BB18244's Avatar
    Ok, RU getting any messages? Like asking to verify account password? Be sure to erase the stars & re-enter pw if it asks. My pop account required entering the full "pop.XXXX.com" server name. Also the full email address. Also had to set. "Use secure connection" to "TLS, if available". Yours might be different on some of that. If it's not happy with password or security settings it seems to provide a nag of some kind.

    Also, It won't update unless you've set it to refresh. I have mine set to refresh on startup and set refresh frequency to 5 min. if you're not seeing activity, might exit program & start again to force refresh. ??
    i did this but unfortunately when i test the configurations, the pop server always fails for some reason but the outgoing server works. thoughts?
    thanks


    Be Bold. Blackberry 9900.
    06-11-16 11:02 AM
  7. idssteve's Avatar
    Well, with outgoing working, good chance you're pretty close to right on incoming. What message are you getting when it fails?

    Might try setting "use secure connection" to "never" just to try??

    If you're using wifi only for now, might try setting Advanced settings - Connection method to wifi only?

    Need to know what message you're getting when pop server fails. ??
    06-11-16 04:01 PM
  8. BB18244's Avatar
    Well, with outgoing working, good chance you're pretty close to right on incoming. What message are you getting when it fails?

    Might try setting "use secure connection" to "never" just to try??

    If you're using wifi only for now, might try setting Advanced settings - Connection method to wifi only?

    Need to know what message you're getting when pop server fails. ??
    Thank you very much for your responses. I switched it to IMAP and im able to receive email. But the odd thing is, i no longer have the option to send an email! i restarted my phone but still no luck. use secure connection is at never but im really not certain what to do right now. thoughts? thanks again

    Be Bold. Blackberry 9900.
    06-11-16 05:07 PM
  9. idssteve's Avatar
    Hmm. Strange. Might be something your mail service is doing? Maybe they have recommended settings posted somewhere?

    I suppose, if all else failed, you might try setting up separate pop/smtp account for sending and imap for receiving but that's kind of cumbersome.
    Still never heard what the failure messages themselves were? Might be a clue there. Are there any messages associated with imap send failure?
    06-11-16 06:45 PM
  10. BB18244's Avatar
    Hmm. Strange. Might be something your mail service is doing? Maybe they have recommended settings posted somewhere?

    I suppose, if all else failed, you might try setting up separate pop/smtp account for sending and imap for receiving but that's kind of cumbersome.
    Still never heard what the failure messages themselves were? Might be a clue there. Are there any messages associated with imap send failure?
    Not too sure, myself. Everytime I send an email, it just goes to my outbox, but doesn't actually send the message.

    Be Bold. Blackberry 9900.
    06-11-16 07:30 PM
  11. BB18244's Avatar
    Greetings everyone!
    I finally got it to work and this is what i did. First I discovered that gmail is a no-go with Logicmail for some reason. Second, i went on the computer and opened Gmail and clicked the option to create a mail collect. When i entered the email address, it began to give me results if its imap, the proper server links and if its TLS or SSL. BUT DONT SAVE! The email you want to use for logicmail, cannot be collected in gmail or any other server. It has to be "alone" to make a direct connection with the server.
    When I put all the proper settings in, i tested my configurations, incoming (pop/imap) was successful and outgoing server was successful. The email service now works perfect with wifi!
    I hope this helps anyone who wants to setup Logicmail on their 9900!
    I wish you all a great day and good luck!
    cheers!

    Be Bold. Blackberry 9900.
    idssteve likes this.
    06-12-16 08:12 AM
  12. idssteve's Avatar
    Excellent info!!

    Like native "Messages", Logic Mail app can be assigned to the Convenience key to provide rapid email access from inside virtually any other app. JIC someone finds that useful.
    06-12-16 09:24 AM
  13. BB18244's Avatar
    Excellent info!!

    Like native "Messages", Logic Mail app can be assigned to the Convenience key to provide rapid email access from inside virtually any other app. JIC someone finds that useful.
    That's awesome! I'm going to assign my convenience key to LogicMail right now!

    Be Bold. Blackberry 9900.
    06-12-16 09:34 AM
  14. colinstone's Avatar
    Trying to install LogicMail on a 9790 for my gmail account and can't really follow the guidance in the earlier post. LM 2.2.0.85.

    I have set gmail to imap and then have the settings as recommended - imap and smtp server settings, SSL and ports and account user name and password. And set imap in Gmail settings.

    After the initial set up following the logicmail website, the smtp connection is sucessful, but for imap it is unable to open connection.
    Sending an email works.

    PicoMail4Gmail does work with the same settings but is a very clunky. Think LogicMail will be better.
    Last edited by colinstone; 11-26-16 at 01:15 PM.
    11-26-16 12:55 PM
  15. Alan Morford's Avatar
    Greetings everyone!
    I finally got it to work and this is what i did. First I discovered that gmail is a no-go with Logicmail for some reason. Second, i went on the computer and opened Gmail and clicked the option to create a mail collect. When i entered the email address, it began to give me results if its imap, the proper server links and if its TLS or SSL. BUT DONT SAVE! The email you want to use for logicmail, cannot be collected in gmail or any other server. It has to be "alone" to make a direct connection with the server.
    When I put all the proper settings in, i tested my configurations, incoming (pop/imap) was successful and outgoing server was successful. The email service now works perfect with wifi!
    I hope this helps anyone who wants to setup Logicmail on their 9900!
    I wish you all a great day and good luck!
    cheers!

    Be Bold. Blackberry 9900.

    Sorry to dig up an old one but it does seem LogicMail Imap access to gmail is broken. You said you fixed it somehow but while I understand adding email accounts to gmail, I don't understand exactly how you did it. I'd love a bit more detailed explanation. And you have push email working?
    12-11-16 12:27 PM
  16. anon(8063781)'s Avatar
    Hi Alan. Here's a link to my test results from May: Guide: BlackBerry OS 7 (maybe 6) WITHOUT BIS - Page 3 - BlackBerry Forums at CrackBerry.com

    I'd be interested to hear if someone got IMAP working as well.
    12-11-16 09:55 PM
  17. Alan Morford's Avatar
    So I ended up making a gmx account which still wouldn't let me use imap or pop. I'm currently logging into it via logicmail unencrypted. I've set my gmail account to forward new mail there and gmail smtp still works to send. So I guess it's the best I can hope for. Looks like SSL/TLS is broken for older bbs.
    12-21-16 06:33 AM

Similar Threads

  1. Xamarin on BB10
    By ayngling in forum General BlackBerry Discussion
    Replies: 11
    Last Post: 10-17-17, 09:09 AM
  2. Replies: 4
    Last Post: 08-23-16, 07:27 AM
  3. Why does Facebook keep crashing my browser on my Passport?
    By CrackBerry Question in forum BlackBerry Passport
    Replies: 6
    Last Post: 06-11-16, 08:39 AM
  4. Replies: 5
    Last Post: 06-10-16, 12:55 PM
  5. Browser keeps crashing when I try to go on Facebook
    By 7christopherr in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 06-10-16, 06:41 AM
LINK TO POST COPIED TO CLIPBOARD