1. blacked-out's Avatar
    Just bought a 9900 (second hand), it should be simlocked according to the seller, but every option is disabled in the device info. Insert sim card keeps showing on the screen, don't know wich country or what network the phone used to belong to. Probably France, because it is AZERTY and the welcome is in French. Tried difrferent sim cards ???

    Thanks for the help...
    01-25-12 04:33 PM
  2. freethisberrydotcom's Avatar
    Have you tried reflashing the OS?
    01-25-12 07:58 PM
  3. ade_tobat's Avatar
    Better ask the seller again if they really unlocked the phone or not, usually when I buy used unlocked phone I always try using other sim cards in front of the seller so I would know for sure if its unlock or not..
    01-26-12 02:48 AM
  4. infinus's Avatar
    Sometimes phone is not unlocked properly ..
    Perform this test….
    1. Open command prompt and locate loader.exe in you c:/
    2. Then type
    Loader.exe /resettofactory
    3. Hit enter, you will see another black window pops and goes away. It is “reset to factory” without space. This will reset your BB to factory, by doing so… you will loose all you data, IT policy
    4. Then wipe device… (wipe is optional, but it’s good )
    5. Let it boot and then pull battery and insert new sim card…
    6. Once booted…
    7. On BB, go to….. home screen>>options>>device>>advance system settings>>sim card>> type MEPD (all in caps)
    8. Observe screen… and see what options are disabled…
    01-26-12 07:46 AM
  5. blacked-out's Avatar
    Ok, will try it and let you know ASAP,



    Blacked-out
    01-27-12 12:49 AM
  6. blacked-out's Avatar
    Tried everything, reinstalled OS, reset to factory, still the same...
    Insert sim and all the options are disabled ??
    Someone else any ideas ?
    02-05-12 01:18 PM
  7. freethisberrydotcom's Avatar
    Maybe it might be compatible with the network or it is reported lost/stolen.
    02-05-12 06:27 PM
  8. blacked-out's Avatar
    Anyone with the same problem ? Is there anything else i can try ?
    02-08-12 08:22 AM
  9. freethisberrydotcom's Avatar
    Have you tried another SIM from a different carrier?
    02-08-12 08:55 AM
  10. dopke's Avatar
    I might have had the same problem, but it seems to be ok now. I used a new SIM card instead of the one I've been using for 4 years now. The contact on the SIM card wears down over-time, so I think that might have been the problem.
    02-08-12 06:07 PM
  11. freethisberrydotcom's Avatar
    Yes it is a wear and tear issue.
    02-08-12 08:58 PM
  12. blacked-out's Avatar
    i'm going to get me a new sim right away! let you know if it worked, i hope so, i'm getting a bit desperate!
    02-09-12 06:49 AM
  13. blacked-out's Avatar
    New sim, still the same, insert sim on screen, even put extra tape on the back of my sim, no results...
    Other suggestions more than welcome!!! I want this phone to work!!
    02-09-12 10:07 AM
  14. dopke's Avatar
    Well, it went back to "INSERT SIM CARD SOS" today... so it only worked for a bit. I saw another idea, might have been what you did.. but it got it working again (for now at least). I cut-out a small rectangle the size of the sim card (doesn't have to be exact, mine is actually smaller by quite a bit), and slid the SIM card in with the sticky note attached --- hoping to get better/tighter contact between the SIM card and the phone. So far so good, but that's only been 10 min.
    02-09-12 04:06 PM
  15. blacked-out's Avatar
    So there is nothing more i can do ? The phone is garbage ??
    02-11-12 03:23 PM
LINK TO POST COPIED TO CLIPBOARD