05-09-17 01:39 AM
34 12
  1. ire.simo's Avatar
    sorry to bother you, I'm a new user of BlackBerry and I wanted to start with the last model (BB Bold 9900), I picked a bargain on eBay with declared 'continuous rebooting' but with a simple software update (BB OS 7.1) and a new original battery seems it works ok! I can infact switch it on and off and configure without apparent problems and WiFi seems working great...
    The only problem so far is that... besides the phone has been sold as *unlocked* (though it has a Rogers brand logo at the bottom of the keyboard) I cannot use my simcards (an italian and a thai one). The phone keeps saying: "Insert SIM Card' and the 'SOS' marking close to the antenna on the top-right corner of the screen.

    This is what I found out

    1) I checked forums and websites and while accessing the advanced device configuration and typing MEPD, this is what I get:

    SIM Disabled
    Network Inactive
    Netwrk Subset Disabled
    Service Provider Disabled
    Corporate Disabled

    On top of that screen I can read: 'SIM Card: No Valid SIM Card'

    2) If I open Options -> Networks and Connections -> Mobile Network on the right side at the line starting with 'Mobile Network:' there's the name of the carrier (that seems the phone is really capable of accessing the GSM network and the correct one according to the SIM).

    3) In the end the 'BlackBerry Device Analyzer' after running the Cellular Network
    Connection Issues ends with this results:
    Antenna Ready: Passed
    Voice Ready: Failed
    Data Ready: Failed
    Blackberry Ready: Not Run
    And after pushing 'Next' this is the final resolution: 'The SIM Card is invalid or not inserted. Please check your SIM Card'

    4) The telephone looks like new and there are no signs of wear outside and inside. The four golden contacts of the SIM card displacement look brilliant and clean. The insertion of the SIM card seems smooth though steady with SIM card contacts facing down and according mounting specifications;

    5) in the end I checked the IMEI (https://prod.eie.net.au/portal/templ...IMEIInquiry.vm) and it seems that is not blacklisted (though this verification may be inaccurate or at least not completely up-to-date).

    That's it... I also tried reinstalling the software another time but this situation hasn't changed. By the way, can you please tell me what is the difference between 'Disabled' and 'Inactive' in the SIM status windows (after the MEPD typing)?

    Sorry for such a long message but I'm pretty sure this gives everybody as much information as possible as to avoid possible further suggestions and repeated retries...

    Thank you for your kind attention, support and understanding... please let me know if someone knows about a similar behaviour nad may suggest what can I do further (before trying another device unlock, if even possible, or repair...), regards...

    edgarmarin100 likes this.
    03-16-12 11:17 AM
  2. fabio984's Avatar
    Did you solved this issue? I got the same problem with 9810.
    03-19-12 09:37 AM
  3. fabio984's Avatar
    i put some paper on the back of the simcard and now it detects :O
    03-19-12 10:23 AM
  4. jim2222's Avatar
    Any luck with this? I've got an almost identical problem
    03-19-12 03:05 PM
  5. fabio984's Avatar
    as i said, i put some paper in the back of the simcard and it works :O
    03-19-12 03:54 PM
  6. jclopezsmu's Avatar
    I've had the same issue. I just got a new sim card.
    03-19-12 04:45 PM
  7. fabio984's Avatar
    But my simcard was new, the lastest. Problem solved with a sheet of paper.
    03-19-12 05:01 PM
  8. ire.simo's Avatar
    unfortunately I didn't solve the issue yet... Despite retrying with a couple of
    different SIMs (that indeed work on other phones).

    Here you can find some other references since I got some replies and suggestions
    at another forum. Bold 9900 - Insert SIM Card / SOS issue (SIM cards don't work / no mobile network access)

    I tried to make the SIM card thicker by applying adhesive tape and/or a folded paper
    slip but still without success. I keep thinking it's a hardware issue, maybe
    a simple electric soldering that must be fixed...

    In any case this afternoon (around 3PM GMT+7) I'll go for a fix and for further
    information at a local AIS Thai representative since I was also suggested to ask
    for device/SIM registration on the network and I'll get back with the latest news.

    Hopefully I'll manage to make it work

    Thanks for suggestions and support... and those who share the same problem...
    Last edited by ire.simo; 03-20-12 at 12:13 AM.
    03-20-12 12:08 AM
  9. Unlimited90's Avatar
    i think u might need to replace your sim reader. unfortunately, this part is not easy to find.
    03-20-12 06:06 AM
  10. waynetechberry's Avatar
    maybe one of the 6 golden "prongs" on the simcard reader itself has "retreated" further below the line of the reader and is not making contact with the simcard itself.

    take a goooood look and see if all the prongs are in-line .... height-wise
    03-20-12 07:50 AM
  11. blackberry-unlocking710's Avatar
    But my simcard was new, the lastest. Problem solved with a sheet of paper.
    It's not your SIM card... it's the SIM slot, or the battery... or maybe even the sim.. but anyways the problem is with the contact, a paper is pushing it when the battery is attached...
    03-20-12 12:25 PM
  12. edgarmarin100's Avatar
    me too i have the same problem with the bb 9860 ROGERS
    04-12-12 12:47 AM
  13. Shaun Carter's Avatar
    no solution all the way thru the version / bundle releases.... SOS appears for a few seconds then reselects to 3G.

    Carrier Vodacom SA, 128k SIM, 9810 rel 2061

    used Nettrax by ranworx.com and I see 150 no service events recorded by the app.

    I also drop calls and have many daily setup failures compared to my Nokia smart phone....
    11-10-12 11:10 AM
  14. Arlie Magnussen's Avatar
    Hate to ask the obvious, but have you tried it with a ROGERS SIM card or are you trying it with an non-Rogers SIM? Although you bought the handset as unlocked, it seems to me that the mobile is still locked.

    Take it to an unlocking shop and ask them to unlock it. Its only 20 dollars. There is a post above by an unlocking person. Once its unlocked you can get Free sim cards from most mobile networks.
    Last edited by Arlie Magnussen; 09-04-13 at 09:44 AM. Reason: updating incorrect referrence
    12-13-12 08:15 AM
  15. SummerGold's Avatar
    Not sure if you've solved this but I had the same problem the other day. I ended ringing up my service provider who told me to put the problem sim in another phone and put a different sim card in my current phone. I put my problem sim in another phone and then put it back in my current phone and it solved the problem.
    12-13-12 03:59 PM
  16. shergill1997's Avatar
    OMG thanks so much it worked. i had to do it 3 times with different thicknesses until i found the right one, you just saved my 9900!
    01-03-13 06:19 PM
  17. fabio984's Avatar
    OMG thanks so much it worked. i had to do it 3 times with different thicknesses until i found the right one, you just saved my 9900!
    So what you did?
    01-03-13 06:23 PM
  18. Qasim Malik's Avatar
    same problem here bold9900
    01-09-13 06:18 PM
  19. shergill1997's Avatar
    I put a piece of paper over the simcard then put it in so it fit tightly into the sim card slot
    01-09-13 07:52 PM
  20. Qasim Malik's Avatar
    my problem is not solved even with the paper thing
    01-10-13 01:44 PM
  21. ukyolo's Avatar
    Same with my BlackBerry but it's the 9360.. I've tried the paper thing but no look.

    It's a brand new phone and sim
    03-21-13 11:31 AM
  22. Felipe Ferrelli's Avatar
    I fixed the Bold 9900 with paper, I picked one little piece os paper from SIM card size folded twice, it was a bit hard to put it, but it worked.
    07-13-13 09:37 AM
  23. blackhezz's Avatar
    yesterday my bold 9900 had died cuz of low battery,after that i plugged the charger and then it is saying insert sim card on network place it's saying sos i tried everything with the paper thing nothing is happening please help me...
    10-15-13 02:25 AM
  24. blackhezz's Avatar
    not helping pleaseeee help.
    10-15-13 02:29 AM
  25. goodayeh's Avatar
    not helping pleaseeee help.
    Let it fully recharge before attempting anything .
    10-15-13 08:53 PM
34 12