1. mel222's Avatar
    Hi,

    since Google deprecated SSLv3 for IMAP/POP a few weeks ago, it seems neither LogicMail nor PicoMail nor mujMail work with Gmail anymore.

    Is there any way to get a client working or is this an issue of OS 7 itself (because it doesn't support modern TLS versions?)?

    Thanks.
    08-09-16 02:53 PM
  2. anon(3732391)'s Avatar
    If you have Microsoft Office running on your PC, you can set up all your email address's to download to Office OUTLOOK (IMAP/SMTP)
    Ten you can sync it to download to your mobile device.
    08-09-16 05:52 PM
  3. mel222's Avatar
    I'm not sure how this would work. I don't have BIS (if that's important).
    Btw, SMTP does work, because TLS is supported too. The problem is IMAP (or at least POP3, but of course I prefer IMAP).
    08-10-16 04:11 PM
  4. anon(3732391)'s Avatar
    Forget "pop" if you want to access Gmail from other clients.

    imap.gmail.com

    Port 993 SSL

    smtp.gmail.com

    Port 465 or 587 TLS

    Best if you start here and follow the instructions
    https://support.google.com/mail/trou...960?hl=en&rd=2
    08-11-16 10:33 PM
  5. mel222's Avatar
    Best if you start here and follow the instructions
    https://support.google.com/mail/trou...960?hl=en&rd=2
    Yes, they don't work (anymore), because LogicMail and the other clients mentioned use SSLv3 obviously, but Google requires a newer TLS version.

    LogicMail throws exceptions with both settings.

    "SSL" (993):
    org.logicprobe.LogicMail.util.Wrapped
    IOException: Unable to open connection
    "TLS" (993):
    java.io.IOException: Connection closed
    anon(3732391) likes this.
    08-13-16 10:29 AM
  6. anon(3732391)'s Avatar
    YA know you don't even have to go through those email clients
    On your Device go to:
    Settings > Accounts.
    If you already added an account to your device, tap The Add Account icon to add another account.
    Add an email account


    On the Add Account screen, tap Email, Calendar and Contacts.
    Enter the email address.
    Tap Next.
    Enter the password for the account.
    Tap Next.
    Change any additional settings on the page to whatever you desire
    Tap Done.

    I tried this myself and it works. No need to go through any of those email clients.
    If you also receive your email on a computer, make sure you go into the hub settings, tap "Display and Actions" and scroll down to "delete on"
    and choose "hub only." That way it won't delete anything on the server.

    Let me know the outcome!
    Last edited by Lostboy5151; 08-14-16 at 02:37 AM.
    08-14-16 02:07 AM
  7. mel222's Avatar
    YA know you don't even have to go through those email clients
    On your Device go to:
    Settings > Accounts.
    If you already added an account to your device, tap The Add Account icon to add another account.
    Add an email account
    Thanks, but it's OS 7. There are no "Settings" and to add an email account you need either BES oder BIS.
    08-14-16 07:06 AM
  8. anon(8063781)'s Avatar
    Thanks, but it's OS 7. There are no "Settings" and to add an email account you need either BES oder BIS.
    The only way that I've ever been able to get around this issue is detailed here: http://forums.crackberry.com/tips-ho...l#post12441092

    I guess I'll have to edit that post to reflect the changes in gmail. I use GMX as the alternate inbox, and it works really well with POP3. LogicMail does not maintain an IMAP IDLE connection with GMX, but mujMail or PicoMail might work better.
    Last edited by Shuswap; 08-14-16 at 05:11 PM. Reason: Additional Details
    08-14-16 05:07 PM
  9. anon(3732391)'s Avatar
    OS 7??????
    Minor detail we probably should have talked about. but no matter. I love playing with all these keys and someone did come to the rescue. And I just love happy endings!

    Good call Shuswap! This better work or you'll ,no doubt, have an angry mob after you!
    anon(8063781) likes this.
    08-18-16 01:02 AM
  10. mel222's Avatar
    OS 7??????
    Minor detail we probably should have talked about.
    What? It's the forum for the 9930/9900. What else it should be running?
    08-19-16 02:41 PM
  11. anon(3732391)'s Avatar
    I picked it up in the BB10 Forum!

    You might want to recheck it. only one other member answered which tells me you're in the wrong area.
    I may be wrong but having 24 thousand more posts than you.....

    I suggest, you always include your Device Name and OS.
    08-20-16 12:44 PM
  12. mel222's Avatar
    You might want to recheck it.
    Ok, I did. Looks like the right place...



    Another one could be "BlackBerry 7", but I asked here, because I believe here are still more users around.

    Anyway, I just don't understand why it doesn't work, when according to the sites writing about this, IMAP (and POP3) has now the very same TLS that SMTP had all the time. And yes, it did worked for years without issues. But now only SMTP does.

    08-21-16 12:12 PM
  13. ohaiguise's Avatar
    I'm not sure how this would work. I don't have BIS (if that's important).

    I would say that it's fairly important. A BBOS device without BIS really isn't much use.
    08-21-16 04:11 PM
  14. uxWare's Avatar
    gmail AND hotmail (outlook.com)

    its an issue with SSL certificates IIRC, I tried to load some certificates (some via the BB desktop, other via the web browser), did not solve it. Maybe the certs should be injected into the source of the Logicmail ( source of LogicMail ) like eg the Mujmail, uses its own certificate and can access email from google, but sadly does not work over wifi.
    Last edited by uxWare; 08-22-16 at 06:09 AM. Reason: typo
    08-21-16 04:21 PM

Similar Threads

  1. Replies: 8
    Last Post: 09-02-16, 04:48 AM
  2. Cannot install Blackberry Link for my Z10 on my laptop
    By Ranger_Rick in forum BlackBerry Z10
    Replies: 4
    Last Post: 08-10-16, 04:53 PM
  3. Replies: 4
    Last Post: 08-09-16, 04:17 PM
  4. Are there SMS push apps for OS 7(BB Bold 9900)?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 08-09-16, 07:45 AM
LINK TO POST COPIED TO CLIPBOARD