1. Chaotic_Cannon's Avatar
    Hi,

    I have already searched the forums here, and on other forums elsewhere. I have tried some of the solutions proposed in other threads as well as called various places and still have not a working solution. I will provide the background information now.

    Phone: Bold 9900

    Carrier Info: Phone purchased (bought fully) from Rogers in Canada and unlocked and it is used on the NetCom network in Norway.

    Issue: BIS (BBM and appworld, etc) works in Norway. I came back to Canada for the holidays. BIS worked in Amsterdam and Toronto for the 4+ hours my wife and I spent waiting for flights. Arrived in Newfoundland and BIS worked for the first day.

    We were roaming on a mixture of Telus/Bell/ and Newtell towers. It was working fine near the airport (where we stayed at a airport hotel) and at the shops near the airport, and the shops closer to the city (about 10 km away).

    We drove for a few hours to reach relatives and my wife connected the BOLD to the house wifi. She has been using wifi ever since and never noticed BIS stopped working via the mobile/cellular towers.

    We drove into the city yesterday and has no BIS for the entire day. Checked the options in the phone and it said BIS is not connected. Visiting friends and connected to their wifi and it works. Leave the wifi and it does not work.

    Called Rogers (where we bought the phone). They wont offer help. Called RIM directly, and they wont help unless a carrier calls them directly to give them a case number. Called my Carrier NetCom in Norway and they have no clue on the issue or how to help.

    After doing research I think it might be a case of the data plan is locked into a specific tower since we were roaming? I told NetCom that and they did not know what to do. I told Rogers that and they said they can help, transferred me to another tech and he placed me on hold for 35 min to chat to another person to ask if they are allowed or can help and never came back.

    I have tried sending a new registration request for a Host Routing Table under the advanced options. It just states the "registration message sent" and that is it. Been 2 days and nothing.

    Battery pull does nothing.

    I am in a bad situation as I bought the phone from 1 company, but use it in another country that has bad BB support.

    Can anyone help please?
    12-31-11 09:39 AM
  2. lcohen999's Avatar
    Go to wireless settings, Mobile Network, Data Services and set While Roaming to ON
    12-31-11 09:41 AM
  3. Chaotic_Cannon's Avatar
    Go to wireless settings, Mobile Network, Data Services and set While Roaming to ON
    Hi, thanks for the reply.

    That is already enabled and has no effect. We had BIS working for 1 1/2 days before BIS stopped working while roaming. We did not change any settings on our own until after the issue started.
    12-31-11 10:03 AM
  4. Mark PPG's Avatar
    According to my freind in NL there are places where there is no data available. Maybe you're in a place where that is the case?

    Mark
    @allaboutmybb
    www.allaboutmybb.com

    Posted from my CrackBerry at wapforums.crackberry.com
    12-31-11 11:39 AM
  5. Chaotic_Cannon's Avatar
    That thought crossed my mind but I do know for a fact that data is available as all my relatives and several friends have BB's and use BBM and app world on a regular basis here.

    Like I said it was working and then it was not! It has something to do with roaming and being locked to a specific tower or some form of that. Some people mentioned in other places that routing table had to be looked at (and as mentioned above that had no affect).

    Calling Rogers and BB was no help either.
    12-31-11 11:46 AM
  6. belfastdispatcher's Avatar
    The first point of call is your carrier in Norway, only they can enable and disable roaming on your account, calling rogers and rim makes no sense.

    Maybe you went over a specific roaming data limit after which roaming gets disabled (normal in europe after people complained of huge roaming data bills)

    I don't know about Norway bur roaming from UK to North America it costs 8 for 1mb so depending on how much you used it already you could've easily reached quite some charges.
    12-31-11 12:53 PM
  7. belfastdispatcher's Avatar
    Also you can manually try to roam to a different network.
    12-31-11 12:55 PM
LINK TO POST COPIED TO CLIPBOARD