1. Deibero's Avatar
    I have a Rogers 9900...

    The phone works fine all day, but there are periods of 5 mins that the screen goes completely nuts, starts clicking all over the place and not even a baterry pull will fix it, it will restart and go back at it again until after locking it a few times it stops...

    It happens mainly when i try to use it with the touch, and not with the trackpad; it starts unresponsive and then it enters the crazy period.

    I have had the phone for 5 days, and it happened every day. I noticed that its always at the same time, when i plug it off the charger in the mornings, and sometimes when my finger is a little humid.

    Is this a device hardware problem? I loaded the new OS and couldnt fix it.

    Could it be that im using the old charger?

    I wish i can return it but im not using it in Canada.

    Any ideas?
    09-18-11 08:47 PM
  2. Deathcommand's Avatar
    It uses electricity.
    do you happen to be standing near a Tesla Generator? lol
    09-18-11 09:13 PM
  3. albee 1's Avatar
    Take it back before your "return and exchange for new" period runs out." I thimk that is what I would do. Best of luck. i

    Posted from my CrackBerry at wapforums.crackberry.com
    09-19-11 12:12 AM
  4. mhw100's Avatar
    if you're not running a conflicting app that isn't supported on os7 then it sounds like hardware I'm afraid. just ship it back to canada or to a friend if you have one there if the carrier won't ship out a unit to another country.
    09-19-11 12:23 AM
  5. blackberry-unlocking710's Avatar
    Ship it back fast while you still can do it.
    09-19-11 03:12 AM
  6. Deibero's Avatar
    could this be to the fact that my BES never actually completed they sync process and maybe its an error? or that should be unrelated?
    09-19-11 11:53 AM