1. stokie77's Avatar
    Hello folks,

    Just come back to BB from an iPhone 4 and 3GS before that.

    My car stereo has a usb input and is marked as iPod ready.

    Plugged in my 9900 and was nicley suprised to see the songs play and titles on the display etc.

    Have moved the sogs from internal memory to new 8Gb card, plug phone into stereo - "No Music".

    Is there a setting i need to activate, or a way i need to transfer music to the card to make it play, or any other reason why the stereo would see music on internal memeory but no the SD card?

    All answer gratefully recieved.
    08-31-11 05:07 PM
  2. rntfuture's Avatar
    I had the same problem, the solution is simple: just restart your phone and you can start listening to your music! Good luck! Greetings, Marijn de Boer (the Netherlands)
    08-31-11 05:38 PM
  3. stokie77's Avatar
    Thanks for the reply Marjin,

    Unfortunately this didn't work, tried 3 times, both with the phone plugged into the stereo and also with it notm

    Can anyone else suggest anything a can do, seems stupid that it can't recognise the memory card music!

    Thanks in advance

    Posted from my CrackBerry at wapforums.crackberry.com
    09-01-11 11:39 AM
  4. SlcCorrado's Avatar
    Thanks for the reply Marjin,

    Unfortunately this didn't work, tried 3 times, both with the phone plugged into the stereo and also with it notm

    Can anyone else suggest anything a can do, seems stupid that it can't recognise the memory card music!

    Thanks in advance

    Posted from my CrackBerry at wapforums.crackberry.com
    Just received my 9900 this morning. It WILL NOT recognize any sd card I put in it. I have tried reboots and setting changes... Is anyone else having this problem??? I'm completely stumped. Almost think it's hardware related in which case mr. ebay seller is going to get an earfull
    10-29-11 05:46 PM
  5. ibcop's Avatar
    Just received my 9900 this morning. It WILL NOT recognize any sd card I put in it. I have tried reboots and setting changes... Is anyone else having this problem??? I'm completely stumped. Almost think it's hardware related in which case mr. ebay seller is going to get an earfull
    Take the memory card out of the device. Format it using your PC. Then reinstall in your device. Then format the card with the device. You should be good to go. Just make sure you copy any files on the card to your PC before you format it.
    10-29-11 06:09 PM
  6. SlcCorrado's Avatar
    Didn't work...
    10-29-11 08:36 PM
  7. albee 1's Avatar
    Just received my 9900 this morning. It WILL NOT recognize any sd card I put in it. I have tried reboots and setting changes... Is anyone else having this problem??? I'm completely stumped. Almost think it's hardware related in which case mr. ebay seller is going to get an earfull
    I found out after playing with mine you can push the sd Card in too far and not far enough. Mine works when pushed in just past the bottom border of the frame, too far and it is invisible, same goes for in all the way. Fyi.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-29-11 09:22 PM
  8. SlcCorrado's Avatar
    I found out after playing with mine you can push the sd Card in too far and not far enough. Mine works when pushed in just past the bottom border of the frame, too far and it is invisible, same goes for in all the way. Fyi.

    Posted from my CrackBerry at wapforums.crackberry.com
    Jeeez, I got so excited when I read this... I'll keep trying but so far no go
    10-29-11 09:46 PM
  9. albee 1's Avatar
    Jeeez, I got so excited when I read this... I'll keep trying but so far no go
    Make sure the contacts are facing down!

    Posted from my CrackBerry at wapforums.crackberry.com
    10-29-11 10:25 PM
  10. taajir's Avatar
    Does the sd card work in another phone?

    Posted from my CrackBerry at wapforums.crackberry.com
    10-29-11 11:54 PM
  11. SlcCorrado's Avatar
    Make sure the contacts are facing down!
    Haha thanks... Yeah I got that far

    Does the sd card work in another phone?
    Sure does
    10-30-11 12:08 AM
  12. tard44's Avatar
    ...since I don't own a car (I'm a biker) this really is a bit of a shot in the dark but I was just thinking, have you tried to plug the phone into the USB and opened any other files you have on the card, like photos or anything? Perhaps it's just acting the same way as when you plug the phone into a laptop USB which can't access anything on the card when in mass storage mode? In other words, altho' it's iPod ready, maybe it'll only charge the 9900 rather than allow you to use the card? As I say, just a guess...
    10-30-11 01:25 AM
  13. SlcCorrado's Avatar
    ...since I don't own a car (I'm a biker) this really is a bit of a shot in the dark but I was just thinking, have you tried to plug the phone into the USB and opened any other files you have on the card, like photos or anything? Perhaps it's just acting the same way as when you plug the phone into a laptop USB which can't access anything on the card when in mass storage mode? In other words, altho' it's iPod ready, maybe it'll only charge the 9900 rather than allow you to use the card? As I say, just a guess...
    I appreciate the input However, it is not "mass storage mode" related. Already been checked. I talked to tech support for a while yesterday and it's starting to become clear this is a hardware issue. Has no one else experienced an all out failure of the card reader???
    10-30-11 10:28 AM
  14. Guzman's Avatar
    Hey guys i had the same problem and i actually fixed mine just now while reading this. Here's how:

    1) Make sure SD card inserted all the way and the BlackBerry ON
    2) Navigate to options > Device > Storage >
    2a) If your page says media card total space ## and Free Space ## then your card is read so just format it.
    2b) If your page shows no media card inserted open your battery compartment and while your battery is IN, pull the card out until it touches the battery (DO NOT REMOVE THE CARD)
    3) Now, slowly push the card back in until your BlackBerry shows the memory card has been read. It will most likely ask for you to format.

    I hope this helps someone, as it is how I got mine finally working. Probably some hardware mis-measurements but, regardless, if it works i'm happy.
    11-01-11 09:59 AM
  15. SlcCorrado's Avatar
    Hey guys i had the same problem and i actually fixed mine just now while reading this. Here's how:

    1) Make sure SD card inserted all the way and the BlackBerry ON
    2) Navigate to options > Device > Storage >
    2a) If your page says media card total space ## and Free Space ## then your card is read so just format it.
    2b) If your page shows no media card inserted open your battery compartment and while your battery is IN, pull the card out until it touches the battery (DO NOT REMOVE THE CARD)
    3) Now, slowly push the card back in until your BlackBerry shows the memory card has been read. It will most likely ask for you to format.

    I hope this helps someone, as it is how I got mine finally working. Probably some hardware mis-measurements but, regardless, if it works i'm happy.
    This is pretty much what Albee 1 suggested. It didn't end up working at all. Returned the phone.
    11-01-11 02:53 PM
LINK TO POST COPIED TO CLIPBOARD