1. dimm0k's Avatar
    I have the 9930 and have had it for quite a while now. About a month or so ago I swapped the battery for an identical stock battery and since then the battery life has been great. Problem is now my phone won't stay on if it's not plugged into a charging source. This past Friday the phone was roaming for a good part of the day so by the end of the day I was around eleven percent before throwing it into a friend's car charger. Didn't charge it too long before unplugging but shortly after that the phone turned itself off. Figured it was a fluke then and didn't worry about it until this morning. For the entire weekend the battery was charged at night and proceeded to work fine throughout the day. This morning I had the phone fully charged, however about thirty minutes into my commute the phone turned off. Any attempts to turn the phone on was futile. Only way was to pull the battery which had the phone boot fresh again. It didn't take long before this happened again... as of this moment this has happened a good 5-6 times. The only way to keep the phone on is to leave it plugged into a charging source. If I disconnect regardless of the battery level it'll turn itself off within the hour. Now my question is, has anyone had this problem before? I'm guessing it's the battery, but I don't want to shell out cash for a new battery only to find out that it's something internally with the phone. If it is the phone then perhaps it's a sign to upgrade phones. Anyone?
    01-13-14 12:51 PM
  2. middbrew's Avatar
    I can't say for sure, but the only time that has happened to me was with my 9650. It ended up being the battery needing replaced.
    01-13-14 03:49 PM
  3. dimm0k's Avatar
    That's what I'm betting on as well... the only thing I can think of that may have caused this problem was using the friend's car charger... hopefully that only damaged the battery and none of the internals. Will know in two days when a new battery arrives!
    01-13-14 04:03 PM
  4. middbrew's Avatar
    Good luck. Hopefully the phone is ok.
    dimm0k likes this.
    01-13-14 04:17 PM
  5. dimm0k's Avatar
    Well it looks like it might be a hardware issue, strangely but specifically Bluetooth. After my original post I placed an order for a new battery, which I received today. The only thing different today is that I had forgotten to tap the NFC tag last night which turns off Bluetooth and switches sound profiles so when I left this morning my Bluetooth was still on. This actually allowed me to have the phone powered on all the way to work and that's when I realized this may not be an easy problem to fix. Unlikely an OS issue I wiped the phone anyway and started with a fresh OS. With Bluetooth still on the phone was okay, but as soon as I unplugged the phone turned off. Later in the day when I popped in the new battery the same thing happened! Now I'm stuck with an extra battery and a replacement keyboard that I was going to install due to the 0 key misbehaving. Anyone know of a fix for this Bluetooth thing? Tried searching for it, but it looks like only a small handful have had this problem and their only resolution was to leave Bluetooth on.
    01-15-14 08:01 PM
  6. BerryRipe's Avatar
    You may want to try cleaning the battery connections but my guess it's the battery. Do you still have the original battery, pop it in to compare. Good luck.

    Keep The Faith ? BlackBerry Q10 ?
    01-15-14 08:06 PM
  7. dimm0k's Avatar
    I've tried cleaning the battery contacts before placing the order for a new battery... unfortunately this is happening regardless of which battery I put in.
    01-15-14 10:05 PM

Similar Threads

  1. Brand New Blackberry Accessories (updated)
    By RideRed250 in forum Buy, Sell, Trade - Sold / Archived
    Replies: 67
    Last Post: 02-04-14, 11:14 AM
  2. Replies: 7
    Last Post: 01-13-14, 03:57 PM
  3. Malfunctioning Speaker: Battery pull redux
    By gabedabomb in forum BlackBerry Q10
    Replies: 2
    Last Post: 01-13-14, 03:28 PM
  4. Group posting extremely slow, battery hot, resets
    By UlfE in forum BlackBerry Q10
    Replies: 2
    Last Post: 01-13-14, 12:07 PM
LINK TO POST COPIED TO CLIPBOARD