1. sx4dude2013's Avatar
    So everytime I talk on the phone and hold it up to my ear, the ear/ear ring hits the damn speakerphone button and turn on the speaker phone via the touch screen. Its accidentaly happened on 5 outa 5 phone calls today .
    Any way to fix this BESIDES have to manually lock the screen via the top button everytime I'm on a call?

    Posted from my CrackBerry at wapforums.crackberry.com
    08-21-11 05:06 PM
  2. mingwu1231's Avatar
    i have the same issue as well.. the best way to solve it. when you talk on the phone, make sure the touchscreen will not "kiss" your face...
    08-21-11 05:48 PM
  3. FBA's Avatar
    It has a proximity sensor just for that reason. The screen should go blank within a second or two of putting the phone to your face...does it NOT do that?
    08-21-11 05:49 PM
  4. Tomo1971's Avatar
    Have a screen protector on?
    08-21-11 05:53 PM
  5. sx4dude2013's Avatar
    No screen protector.
    I think it does go blank but it doesn't stay blank all the time.
    If I re adjust it or walk around it guess it comes back on and then I accidentatily hit it. Idk. Didn't know if other ppl were having any issues or if there was a fail safe way to fix if for sure? Lol

    Posted from my CrackBerry at wapforums.crackberry.com
    08-21-11 05:55 PM
  6. glassofpinot's Avatar
    On other touchscreens, they soon made inexpensive apps to block this. That will likely happen for this model since it is a hot seller.
    Frequency all depends on your anatomy and position, some have more issues than others.
    Posted fr wapforums.crackberry.com[/QUOTE]
    Last edited by glassofpinot; 08-21-11 at 10:38 PM.
    08-21-11 06:37 PM
  7. John Yester's Avatar
    I just tested calling voice mail and mine turns the screen off with in a sec of covering my hand. same result with face.

    No issues.
    08-21-11 06:39 PM
  8. Velize's Avatar
    Yes I have had the same problem. I try to mostly use the headset, and when I don't, I just try to make sure I don't "kiss the screen" with my face...
    08-21-11 11:28 PM
  9. JayInNJ's Avatar
    I have had the same problem occasionally. I think the solution is to make sure the phone stays pressed close to your face. If you keep adjusting the phone or leave it hovering it will not keep the touchscreen disabled.

    Posted from my CrackBerry at wapforums.crackberry.com

    Posted from my CrackBerry at wapforums.crackberry.com
    08-22-11 05:26 AM
  10. harrymole's Avatar
    Me too. Nearly went deaf.
    08-22-11 05:34 AM
  11. sx4dude2013's Avatar
    Me too. Nearly went deaf.
    Lol. I feel ya!

    Posted from my CrackBerry at wapforums.crackberry.com
    08-22-11 06:44 AM
  12. BravoBBY's Avatar
    I have the same issue. If I hold the phone flat against the side of my face it works fine. But I like to hold just the top portion of my phone against my ear and the rest of it not touching my face which causes the speakerphone to accidentally turn on. I hate holding my phone flat against my face cause I am usually sweating and I get sweat on my phone... Makes it look real good. I wish there was a way to disable the touchscreen during calls.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-03-12 09:34 PM
  13. kjjb0204's Avatar
    Get a big magnetic earring so it activates the sleeper function. Maybe I can patent that as a bb accessory.
    01-03-12 11:46 PM
  14. cooljatt18's Avatar
    definitely something wrong with the way you hold your phone, you will get used to. gently hold the phone earpiece sticking with your ear and don't move your hands much coz when you do the proximity sensor lights up the screen and then when you press the phone back with your cheek the on screen speaker is activated. faced the same problem on my N8 but got used to it.
    01-04-12 02:09 AM
LINK TO POST COPIED TO CLIPBOARD