1. BarryBaas's Avatar
    It keeps putting the call on speaker or even on hold when I accidentally touch the screen with face. Really annoying. Is there a way to auto-disable the touchpad while making a call?
    09-01-11 02:15 PM
  2. o4liberty's Avatar
    Your screen should go blank with proximity sensor.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-01-11 02:19 PM
  3. Fnord's Avatar
    Do you have a screen protector on?

    I remember that causing issue on the Torch 1 when it came out...
    BarryBaas likes this.
    09-01-11 02:24 PM
  4. BarryBaas's Avatar
    Do you have a screen protector on?

    I remember that causing issue on the Torch 1 when it came out...
    Yes, sort of.. Because the leather sleeve that comes with it is very tight I didn't take off the screen foil yet. I planned on doing this when I used the sleeve for a few days so it would be a little bit looser. So it should be oke when I remove this?
    09-01-11 02:43 PM
  5. Fnord's Avatar
    The proximity sensor is just to the immediate left of the msg LED. Try cutting the foil around just the area and see if it helps.

    You can test it out by placing a call (eg to voicemail) and placing a finger over that spot. If it's working correctly the screen will go dark. Lift your finger and the screen will come back on...
    09-01-11 02:50 PM
  6. Sharma15's Avatar
    Proximity sensor never failed me yet... Most screen protectors have a little cut out for the sensor and led.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-01-11 04:05 PM
  7. joju58's Avatar
    Yes, sort of.. Because the leather sleeve that comes with it is very tight I didn't take off the screen foil yet. I planned on doing this when I used the sleeve for a few days so it would be a little bit looser. So it should be oke when I remove this?
    you can loosen your case doing this...if you have old blackberry Bold-9000 then set hair blower to hot and blow it on to case till its warm or hot and then place bold 9000 in for an hour or so. From there you good to go using your new phone with this sleeve case. If you don't have old Bold then find something similar sized item and do same.
    09-01-11 04:27 PM
  8. CBKevin's Avatar
    Another option is to download the auto lock program TGrape Lock now. It has a feature that lets you lock phone on connected call. Its not officially supported on OS7 yet but you can still donload it here on Crackberry and it works fine.
    09-01-11 05:03 PM
  9. kjjb0204's Avatar
    If the proximity sensor isn't working, there's something wrong. For now, you can certainly just hit the lock button on top before putting to your face. Not elegant, but quick enough until you exchange or load another OS.
    09-01-11 05:05 PM
  10. BarryBaas's Avatar
    Thanks everyone. I took off the foil and no speaker or call on hold on my first call. So far, so good!
    09-02-11 02:19 AM
  11. Netman2008's Avatar
    Ok I have tried TGrape for a few days and it seems to work just fine however this has been a serious issue for me and I can not believe RIM has no fix for this. I was at the point of not wanting this 9900 anymore.
    If anyone has any other info or suggestions I would like to hear them.
    Thanks

    Even though I am a SERIOUS ANTI Apple guy ............... RIP Steve
    10-06-11 11:30 AM
  12. Fnord's Avatar
    Ok I have tried TGrape for a few days and it seems to work just fine however this has been a serious issue for me and I can not believe RIM has no fix for this. I was at the point of not wanting this 9900 anymore.

    If anyone has any other info or suggestions I would like to hear them.

    Thanks



    Even though I am a SERIOUS ANTI Apple guy ............... RIP Steve

    What would a RIM fix be?

    Either you have something blocking the sensor (ie screen protector), problem OS, or defective device.

    If you don't have a screen protector on and have tried re-loading the OS with no result then you need to exchange the device. Nothing RIM can provide that will fix the problem for you...
    10-06-11 12:41 PM
  13. FBA's Avatar
    A clear or even anti-glare screen protector doesn't interfere with the proximity sensor on any of my 9900's. I can't accept that the original RIM protector was interfering with the OP's calls...doesn't wash with me.
    10-06-11 01:15 PM
LINK TO POST COPIED TO CLIPBOARD