1. Punjabi Geezer's Avatar
    Hi can anyone help.

    I bought the 3500MAH battery from e-cell on ebay.
    I put the battery in the phone and get the battery with the cross symbol.
    I then remove the battery. Put the original battery in the cloner and then the 3500 battery.
    The LED on the cloner lights up for a split second then goes off.
    I then put the 3500 battery back in the phone and get the same battery with the cross again.

    From what I understand the cloning process should take a few seconds so I think it's going wrong there. I've left the two batteries in together for a couple of minutes even thought the LED is off but that hasn't made a difference.

    Anyone got any ideas?
    02-03-12 06:12 PM
  2. doby-nut's Avatar
    Purchased the same items for both my wife and I, had to put pressure on ext battery towards pins to clone in tray.
    Not happy with batteries as within a few days both ext battery doors tabs fell off.
    Good luck.
    02-03-12 06:19 PM
  3. Punjabi Geezer's Avatar
    gave it a good squeeze down but still no joy

    any other ideas?
    02-04-12 05:12 AM
  4. greggebhardt's Avatar
    gave it a good squeeze down but still no joy

    any other ideas?
    Garbage can
    02-04-12 06:16 AM
  5. Punjabi Geezer's Avatar
    Garbage can
    I think that is gonna be the plan tbh lol!
    02-04-12 05:50 PM
  6. deezy87's Avatar
    Punjabi Geezer, or anyone here for that matter. Does anyone know if RIM will be releasing an extended battery? I had to go to a job interview yesterday, took the phone off of charge at about 8am and around 2:30pm it was dead. Like radio shut off dead.
    02-04-12 06:23 PM
LINK TO POST COPIED TO CLIPBOARD