1. leejoseph's Avatar
    Ok so Maps was installed on my Bold 9900 (Sim Free, using Orange carrier) but I had to search for it on the spotlight search to find it, it was nowhere to be found, not hidden etc.

    So I deleted it using the app manager and have since tried to re-install it, however using the BB browser it tells me my device is not supported?

    I have a mac so using the app loader isn't the best and plus it does not list BB Maps there to install.

    Any ideas?
    09-01-11 06:33 AM
  2. diffused's Avatar
    You can go here to download from your blackberry. Select a Country
    09-01-11 08:39 AM
  3. nemehazo's Avatar
    Hi diffused .. thanks for replying to this. I tried to use this link from my Sprint 9930 (Sprint), but strangely I get an error message that my system configuration is not supported!

    Please note that I have stock version .241 loaded. I ran into error 102 the other day and had to reload the software thru desktop manager. Since then, BB Maps is missing, and I want it desperately back!!

    Any other suggestions for me please?
    09-18-11 04:31 PM
  4. tiguy74's Avatar
    \did you ever find a solution to this problem ?? I am going through the same thing right now.. I cant find a working download link
    09-24-11 10:28 AM
  5. belfastdispatcher's Avatar
    You can only get it again using the Desktop Manager, connect your blackberry to it and click on aplications and then on the + sign beside the Maps

    Posted from my CrackBerry at wapforums.crackberry.com
    tiguy74 likes this.
    09-24-11 10:54 AM
  6. tiguy74's Avatar
    thanks !!

    i ended up doing it this way, similar to what you said..

    =====Well, no one chimed in, but I figured it out. I thought I will update here so if someone else stumbles on this thread, atleast THEY have some help!

    I basically ran what is called "App Loader" application. This app is bundled with BlackBerry Desktop Manager on Windows machines (it might be on Mac too, didn't try there). You don't have a link to it in start menu - you have to explore C drive to find it in Program Files >> Common Files >> Research In Motion folder.

    I ran the app, selected the missing components (apparently I was also missing Social Feeds, Docs to Go and some other apps too!). And after a few minutes of magic, the applications were back!

    I don't know how they got removed (I had a error 102 recently, I have a feeling that it wiped it out).

    Oh well. It's fixed now!======
    09-24-11 11:09 AM
LINK TO POST COPIED TO CLIPBOARD