1. JR A's Avatar
    I have a Verizon 9930 running .374

    Whenever I make or receive a call, the phone goes black and I can't access any of the options or even menu. The screen stays black.

    Not even the unlock key at the top of the BB brings the screen back. I have the press the $/speakerphone button on the lower right of the keyboard. That is the only button that will bring the call screen back up.


    And in some cases, the call screen will come up, then go back to black, come back, go back to black...


    Any ideas on how to fix this?




    UPDATE NOVEMBER 14th 2011:

    Following post was taken from another thread I posted in...

    It has to do with the proximity sensor messing up. It thinks your phone is held up to your face thus initiating "sleep mode" on your screen.

    On my BB, the only button that works (other than the end button) is the speakerphone/$ button on the keyboard. If you press that while in a call, it should turn speakerphone on and "turn on" your screen, which will allow you access to it.


    But for some reason it's now magically fixed

    However, I think it had something to do with an existing app on my device causing this bug.

    I was going to wipe my entire phone and reinstall .374 (Verizon). I however just wiped "Installed Apps" in the security wipe section, and after the phone rebooted, someone called me and I noticed this "bug" was fixed.

    -----------------------------------------------------------------


    So, I don't know if an OS update will fix it, or if choosing the option to delete all installed apps in the Security Wipe section will do it. I just know that I downloaded .374 (latest build for Verizon) and the problem was still there until I deleted all my installed apps. Now everything works fine


    Also, I have NOT tried this supposed solution, but here's a link to a walk through if you're interested:

    http://forums.crackberry.com/blackbe...te-fix-669478/


    If anyone tries the steps in that walk through, let me know how it worked out for you.
    Last edited by jranciano; 11-15-11 at 03:42 PM.
    10-21-11 08:32 PM
  2. chustle925's Avatar
    Do you have a case on your phone? Sounds like something is interfering with the proximity sensor. Hope this helps.
    10-21-11 10:48 PM
  3. JR A's Avatar
    Thought it would be the proximity sensor, but I don't even have a screen protector on it...


    It's still doing this.
    10-23-11 03:58 PM
  4. Gees97's Avatar
    Hey holy ****! Me tooooooooo 9930/7.0.0.374 on VZ but it did it on my last leaked OS too

    Posted from my CrackBerry at wapforums.crackberry.com
    10-24-11 05:43 AM
  5. SourBB's Avatar
    I had this issue with my stock VZW 9930, I upgraded with the leaked VZW update and fixed that problem. And its not an issue with the proximity sensor, its something else definitely

    Posted from my CrackBerry at wapforums.crackberry.com
    10-24-11 10:33 AM
  6. SourBB's Avatar
    Whoops double post...
    10-24-11 10:39 AM
  7. sherifbmw's Avatar
    i have the same issue on 9900 with 2 os builts 353 and 439
    10-24-11 10:45 AM
  8. rqcraig's Avatar
    I'm running also running .374 on VZW and haven't seen this. I never experienced it on the stock OS either. Just curious, does it lock out on the black screen immediately upon making/receiving a call or does it lock after your backlight timeout setting expires? What is your backlight timeout setting?
    10-24-11 01:30 PM
  9. JR A's Avatar
    I'm running also running .374 on VZW and haven't seen this. I never experienced it on the stock OS either. Just curious, does it lock out on the black screen immediately upon making/receiving a call or does it lock after your backlight timeout setting expires? What is your backlight timeout setting?
    My backlight timeout is set to 30 seconds.


    It happens almost instantly after I press the Send button when I make a call. And in many cases, the call screen will come up and fade back to black several times while on a call.

    I thought it was the proximity sensor, but I tested phone calls with the phone lying flat on my desk and then tested it with my finger covering the sensor. Same results either way.


    Again, the only way I can access the phone is to press the $/speakerphone key. The unlock, menu, send, and return buttons have no effect to bring the screen back up either...
    10-25-11 08:32 PM
LINK TO POST COPIED TO CLIPBOARD