1. Knocks's Avatar
    Some of my incoming calls pop up as numbers only, even though I have phonebook entries for those numbers. When you access the call via the call log later, it will show up with the proper name entry. Never had this problem before upgrading to the 9930 (my previous phone was Tour 9630).

    Things that might affect my phonebook: BES, BIS Gmail, and Google Sync.
    09-19-11 02:31 PM
  2. Knocks's Avatar
    Someone suggested that some of my phonebook entries might have a +1 and others use ( ) for area code, but that I haven't determine that to be the cause with any sort of consistency.
    09-26-11 01:20 AM
  3. o4liberty's Avatar
    I would check with your carrier they might have a fix. I am with Verizon and haven't seen that problem yet.
    09-26-11 06:01 AM
  4. chaddeus's Avatar
    Some of my incoming calls pop up as numbers only, even though I have phonebook entries for those numbers. When you access the call via the call log later, it will show up with the proper name entry. Never had this problem before upgrading to the 9930 (my previous phone was Tour 9630).

    Things that might affect my phonebook: BES, BIS Gmail, and Google Sync.
    Go to Options > Call Management > Smart Dialing. Make sure your country code is correct and the National Number Length is correct.

    - Charles
    09-26-11 07:53 AM
  5. Knocks's Avatar
    Go to Options > Call Management > Smart Dialing. Make sure your country code is correct and the National Number Length is correct.

    - Charles
    That solution doesn't make sense, because it only happens sometimes. It is also not consistent about which numbers it happens to. The same number might show up with a name once and without the next time.
    09-26-11 10:00 AM
LINK TO POST COPIED TO CLIPBOARD