1. Danboy900's Avatar
    I have just this evening opened my new Blackberry Bold 9900 to only have it on charge for 2 hours and it still not allow me to turn on. All that i see on the screen is a battery images with a cross through it, and a hourglass spinning in front of that. Its still doing it now whilst on charge. I have tried different plugs and 2 different chargers from previous BB's and still not working!

    I have done a battery pull and when i put it back in the same happens again!!! Have i got a faulty phone from Vodaphone? Or is do i have to do a long charge overnight as its a new battery?

    Thanks in advance!
    09-29-11 04:50 PM
  2. OniBerry's Avatar
    Soft reset of your phone (Alt+Shift+Del) and then try connecting to your Desktop Manager.
    09-29-11 05:34 PM
  3. NubianShadow's Avatar
    Hiya

    Having exactly the same problem as above, phone has been charging for 3 hours. I tried plugging into my MAC but it did not recognise it. Also there was no seal and no disc in the box, does that mean I have a dud refurb?

    Thanks in advance for all help
    10-05-11 04:14 PM
  4. Nickbh13's Avatar
    Hi Dan

    Had exactly the same this week, put battery in, red light comes on, then goes off, display then shows battery with egg timer in the middle and red cross. Put on charge with no joy and followed a few tips on various sites to no avail.

    Took to Vodafone shop and asked if they had a 9900 I could put the battery in, and did exactly the same, so popped into Carphone Wharehouse and did the same with one of theirs, and exactly same result. Hasten to add, these were working 9900 before I put my battery in.

    Called Vodafone and they sent me a new battery. I have seen some posts which led me to believe that there might be a battery manufacturing issue, however, have no facts other than the test I did.

    Did try some of the suggested tips, and found unable to use BBSAK as will not connect regardless of suggestions, and using the loader.exe /nojvm also unable to work as battery keeps indicating not present in 9900 when re-initialising.

    Spent a few wasted hours trying suggestions out, but a trip to town soon confirmed the battery was at fault.

    Trust helps

    Nick
    10-05-11 04:27 PM
  5. tonyshep's Avatar
    Something weird going on - I keep having the same issue on my 9930. Sometimes there is a message on the phone that tells me the charging device I am using is not compatible (even the one that came with the phone) and the battery has a black sign in it rather than the lightning bolt that shows it's charging. If I do a soft re-boot with the phone connected to the charging device the battery changes to the lightning bolt and the phone gets charged.
    10-05-11 05:59 PM
  6. mr_gill's Avatar
    Having exactly the same issue here with a new 9900 on T-Mobile UK that got delivered today. Got a new battery being delivered tomorrow, will see if that fixes the issue. There definitely must be a set of dud batteries in the UK as there seems to be a lot of people having this exact issue..
    10-05-11 06:07 PM
  7. NubianShadow's Avatar
    Having exactly the same issue here with a new 9900 on T-Mobile UK that got delivered today. Got a new battery being delivered tomorrow, will see if that fixes the issue. There definitely must be a set of dud batteries in the UK as there seems to be a lot of people having this exact issue..
    Agree.

    Too many people have told me about returning batteries. BB may need to invest more into R&D!
    10-06-11 04:39 AM
  8. dictoresno's Avatar
    battery icon with a line through it usually means bad battery. exchange it for a new one at your carriers store.
    10-06-11 04:46 AM
  9. mr_gill's Avatar
    Got a new battery today, as expected it fixed the issue! By the way, how great is this phone!?
    10-06-11 02:24 PM
  10. Fnord's Avatar
    If your battery indicator has a red X it IS defective. This is known issue with a specific batch of batteries. RIM has notified carriers and they should replace the battery for you.

    Effects a small % of overall shipments prior to mid-sept.
    10-06-11 03:25 PM
LINK TO POST COPIED TO CLIPBOARD