1. ImBerryAddicted's Avatar
    Hi Everyone,

    I've run into a huge issue downgrading my Bold 9900.

    Initially I upgraded to OS 7.0.0.353 and everything seemed fine. After a few days many problems started to appear so I decided to downgrade. Unfortunately my Blackberry refuses to install anything but the OS 7.0.0.353.

    I downloaded 3 different Versions already, uninstalled and re-installed. I even tried running the Desktop Software on Mac - all with the same result.

    In the Apploader it says that there is no software that will fit the Device
    In the Desktop Software it says "Cannot recover blackberry device software. There is no avaliable software for your ..."

    I'm currently on Error 507 because I thought a clean start would help. Unfortunately only OS 7.0.0.353 will install. Nothing Else.

    Any suggestions?
    10-05-11 08:45 AM
  2. NursingNinja's Avatar
    I dont think desktop manager will allow a downgrade when the higher OS is installed. Backup, wipe with BBsak, and then try again. What helps me is when I want to install the OS I actually hook it up to a different computer than the one I backup on. That way I can uninstall desktop manager and reinstall it so there is no chance it has any memory of my device with another OS.

    People on this site say to use the loader.exe to install but that has never worked for me.
    10-05-11 09:05 AM
  3. kashabrown's Avatar
    I recently went through a similar experience - follow NN's advice, however, run the loader.exe (app loader) rather than device manager - once you installed your "lower" OS, it will pick it up and load it up.

    Good luck!
    10-05-11 03:28 PM
LINK TO POST COPIED TO CLIPBOARD