1. Preston129's Avatar
    I've had the Bold 9900 from Rogers for a week now and my screen has developped a permanent horizontal line that goes through the time at the top of the screen (about 1/2" from the top of the screen. The line started by flickering at first but is now permanently visible in all applications, as well as during startup.

    I have pulled the battery numerous times and reloaded the original OS (7.0.0.261) as well as upgrade to 7.0.0.540 and the problem persists.

    Screen capturing doesn't show it so I'd have to take a picture of the phone in order to show what I'm talking about.

    I'm a little confused what the process is now to get this sorted out; the place I bought the phone from (authorized Rogers dealer) said this is now an issue to take up with RIM since they warranty their hardware for a year, but should I instead hassle Rogers directly? Or demand a new phone from the store?
    11-23-11 02:05 PM
  2. Fubaz's Avatar
    i call bull****.
    goto that rogers store and make them take it back

    ask for the manager and if that doesnt work ask for the # of the company who owns the store and most of them are not corporate.
    Also dial 611 from your phone and talk to a CSR.
    11-23-11 02:14 PM
  3. mssca's Avatar
    I think this return policies are depend on the store. But, I would go back and yell at them... I got things done by yelling so many times now.. LOL
    11-23-11 09:46 PM
  4. BarryBaas's Avatar
    I think this return policies are depend on the store. But, I would go back and yell at them... I got things done by yelling so many times now.. LOL
    I skipped yelling and just posted it on my carriers customer forum. They called me back within half an hour, the new device arrived in three days!

    Nice guys finish last...
    11-24-11 07:32 AM
  5. galleon's Avatar
    I would never buy anything from that store again if that's what they do! I have never heard of that before!

    Posted from my CrackBerry at wapforums.crackberry.com
    11-24-11 01:36 PM
  6. AkshayT's Avatar
    I am having the same problem with my Bold9900.
    The line started to appear a few days ago, when I was watching a movie,
    it blinked and went away on its own, but gradually, it got permanent.
    Now whatever facking step I take, reboots, reinstalls, taking out the battery&switching it on... The line wont just disappear.
    And my situation is complicated, I got this T-Mobile device as a gift, 6months ago, from someone who lives in Panama. I live in India. Other than returning the device, what else can I do?
    03-14-12 12:31 PM
  7. lumos#CB's Avatar
    Guys, it's pixel burn! it usually takes down a whole row not just a spot. You have to get your device repaired or replaced.

    I skipped yelling and just posted it on my carriers customer forum. They called me back within half an hour, the new device arrived in three days!

    Nice guys finish last...
    +1 I'd do the same. I wrote corporate regarding my battery and they told me to take it in store where they could replace it.

    It's the information age so use it to your advantage.
    03-14-12 12:53 PM
  8. AkshayT's Avatar
    Guys, it's pixel burn! it usually takes down a whole row not just a spot. You have to get your device repaired or replaced.
    Soo, like a whole new screen for me?
    03-14-12 02:33 PM
  9. byul's Avatar
    Soo, like a whole new screen for me?
    Yes you need a wole new screen. It's not normal so bring it in and get it replaced/repaired.
    AkshayT likes this.
    03-14-12 02:40 PM
  10. Alex_Hong's Avatar
    its definitely not normal. it would likely get a lot worse eventually. a friend's 9900 had this. started out from a small corner of the screen, eventually the whole screen was affected. get it fixed.

    Sent from my BlackBerry Runtime for Android Apps using Tapatalk
    03-14-12 03:32 PM
LINK TO POST COPIED TO CLIPBOARD