1. whit27's Avatar
    Hey Everyone,
    I had a Blackberry 9700 from Wind Mobile and I just recently was given a Bold 9900 from someone I know in the States and its from T-Mobile and its unlocked.

    On my 9700 I had the Mobile Network settings as:
    Network Selection Mode:Automatic
    Network Mode: 3G

    Now with the Bold 9900 there is no 3G option.
    All I have is 2G and 3G/4G & 2G.

    My concern with this is Wind Mobile if you connect to 2G you are not on the Wind Mobile network and will be charged usage fees.

    So when I had the Mode set to 3G it always stayed on the Wind Mobile Home Network. If it couldn't connect it went to an X in the top left till it connected back to the Home Network.

    Is there a way for me to add just 3G to Network Mode on this phone?

    Thanks
    Chris
    02-17-12 10:43 AM
  2. byul's Avatar
    your carrier/mobile network controlls it, you can't change it.
    02-17-12 10:45 AM
  3. whit27's Avatar
    So why was it on the 9700 but not the 9900? Is it because its a TMobile Phone?
    02-17-12 10:49 AM
  4. whit27's Avatar
    and is there away for me to set the network to 3G so I don't get charged or connect to other networks?

    Since I am on an Unlimited Plan with Wind... and its been great so far... But I always knew it would not connect to a different network.
    02-17-12 10:51 AM
  5. Xavier85's Avatar
    Unfortunately i believe this is how os7 is coded, so not really a way to change it. Just one of the subtle differences between os6 and os7. It's not a tmobile brand issue though, i've had both the 9700 and 9900 tmobile versions and that changed for me too once i went to the 9900 and os7.

    Really the only suggestion i could give you is to contact your cellular provider and see if they have any options for you. Good luck!
    02-17-12 10:57 AM
LINK TO POST COPIED TO CLIPBOARD