12-29-11 02:35 PM
34 12
tools
  1. lalido's Avatar
    Bought a used Blackberry Bold 9900 two days ago. Everything working A+

    I forgot to plus in the phone when i went to bed last night and when i woke up this morning it was dead.

    Once i powered it up again, the keyboard, trackpad and all other physical buttons just stopped working?! The touchscreen still works.

    I did several battery pulls and still the same problem!!

    Does anybody have any ideas on how to fix this??

    Thank you
    12-21-11 09:10 AM
  2. MrLynd54's Avatar
    Sorry to hear the buttons don't work. It may need to have the OS reinstalled to get it to work correctly again. Seems a bit extream though.
    12-21-11 09:35 AM
  3. lalido's Avatar
    UPDATE: All of a sudden the trackpad movement has started to work again, not the clicking but i can now use the trackpad to move the selected item
    12-21-11 09:36 AM
  4. lalido's Avatar
    When i come to update the OS in the apploader, the blackberry files are not listed!!!!

    only my thirdparty applications are listed!!

    HELP PLEASE!?!?
    12-21-11 09:46 AM
  5. jiggaman2g's Avatar
    When i come to update the OS in the apploader, the blackberry files are not listed!!!!

    only my thirdparty applications are listed!!

    HELP PLEASE!?!?
    I believe its BBSAK (dont quote me) But there is a program that will do a complete wipe of the device. I would recommend you do that and load .540 OS.

    Do a bit of searching on how to star the process but that should fix your issue.
    lalido likes this.
    12-21-11 10:32 AM
  6. Rootbrian's Avatar
    I believe its BBSAK (dont quote me) But there is a program that will do a complete wipe of the device. I would recommend you do that and load .540 OS.

    Do a bit of searching on how to star the process but that should fix your issue.
    Loader.exe /nojvm might help, from the run command or from the command prompt. Also, OP can remove the battery and connect it to the computer and launch apploader and continue to click Retry until it locks on, let it load the OS, then reconnect the battery once "reconnecting to JVM" is displayed to continue the loading process. That is a complete wipe and clean reload. Works for me.
    12-21-11 11:42 AM
  7. lalido's Avatar
    When i do the Loader.exe /nojvm it says i have no opertaing sysyem installed and to contact my admin.

    Should I procede with a FULL wipe and reinstall an new OS?

    if so what treads should i look at to help me with completly wipeing the advice?
    I frequently install new leaked OS on my devices but ive never done a complete wipe so i do not know how!

    Thank you!!
    12-21-11 11:49 AM
  8. Rootbrian's Avatar
    When i do the Loader.exe /nojvm it says i have no opertaing sysyem installed and to contact my admin.

    Should I procede with a FULL wipe and reinstall an new OS?

    if so what treads should i look at to help me with completly wipeing the advice?
    I frequently install new leaked OS on my devices but ive never done a complete wipe so i do not know how!

    Thank you!!
    You need to download the latest OS 7 device software from your carrier and then install it on your computer, then use the command to launch apploader from the run dialog or the command prompt.
    12-21-11 11:54 AM
  9. lalido's Avatar
    I bought an unlocked rogers phone and i cant find the latest OS from my Service provider (Bell)
    12-21-11 11:57 AM
  10. Rootbrian's Avatar
    I bought an unlocked rogers phone and i cant find the latest OS from my Service provider (Bell)
    Did you go on the blackberry.com website and look under Apps and Software? There is an OS 7 section.
    lalido likes this.
    12-21-11 11:59 AM
  11. lalido's Avatar
    Found Bell's latest OS, installed it to my computer but the Blackberry OS files still dont show up in the Apploader.exe

    Should I procede with a FULL wipe and reinstall an new OS?

    if so what treads should i look at to help me with completly wipeing the advice?
    I frequently install new leaked OS on my devices but ive never done a complete wipe so i do not know how!
    12-21-11 12:10 PM
  12. Rootbrian's Avatar
    Found Bell's latest OS, installed it to my computer but the Blackberry OS files still dont show up in the Apploader.exe

    Should I procede with a FULL wipe and reinstall an new OS?

    if so what treads should i look at to help me with completly wipeing the advice?
    I frequently install new leaked OS on my devices but ive never done a complete wipe so i do not know how!
    If you are on windows XP, hit F3 on the top of your keyboard and be sure to check Hidden and System files and also, subfolders (you can do this on windows 7 too), start within C:\ and search for vendor.xml. There are two or three of them, once the search is complete (it will take some time), delete the files and then, you should be able to reload the OS. But remember to close both loader and desktop manager before doing so. Then launch loader.exe once the files are deleted.
    lalido likes this.
    12-21-11 12:14 PM
  13. lalido's Avatar
    Deleted the hidden vendor.xml
    Installed new OS

    Buttons now work but the scrolling of the trackpad is wierd!
    it doesnt allow me to scroll out of menu
    for example: in the main menu you can scroll between all the icons but not onto the title bar above!

    I know this is not alot to go on but any suggestions?
    youre help is really appreciated!
    12-21-11 12:43 PM
  14. Rootbrian's Avatar
    Deleted the hidden vendor.xml
    Installed new OS

    Buttons now work but the scrolling of the trackpad is wierd!
    it doesnt allow me to scroll out of menu
    for example: in the main menu you can scroll between all the icons but not onto the title bar above!

    I know this is not alot to go on but any suggestions?
    youre help is really appreciated!
    So what you're saying is you cannot move the cursor to the click area to access the mobile network, wifi, status and all? That is definitely weird. I have never experienced that occurrence before. If you cannot click with it, then it's likely a hardware fault.
    12-21-11 12:59 PM
  15. lalido's Avatar
    I can click,i can scroll around but cant scroll to the top

    Im thinking a wipe?
    12-21-11 01:01 PM
  16. Rootbrian's Avatar
    I can click,i can scroll around but cant scroll to the top

    Im thinking a wipe?
    Trying a wipe wouldn't hurt, remove the battery and connect it to your computer, then launch loader and if you get an error saying it cannot detect or connect, click Retry until it locks on. Then let it do the magic. Once it says Reconnecting to JVM, insert the battery and it'll continue the loading.
    lalido likes this.
    12-21-11 01:04 PM
  17. lalido's Avatar
    I wiped the device and did a Security Wipe. Reinstalled OS .590 and still have the same problem

    I turned on the audible roll to see if the trackpad recognizes my movement and it does but its as is i dont touch the part of the screen i want to scroll in, it wont scroll onto that part before (out of the main menu for example)

    Anybody have any more ideas? it would be greatly appreciated!
    12-21-11 02:04 PM
  18. lalido's Avatar
    I found another unanswered post describing the exact same problem i am experiencing!

    Maybe this description of the problem is more clear

    Blackberry bold 9900 problem scrolling - BlackBerry Support Community Forums

    thanks
    12-21-11 02:08 PM
  19. robsteve's Avatar
    You should probably let the person you bought it from know there is a problem and see if they can get Rogers to fix it. You can check to see if it is still under warranty at the link below, but since you are not on Rogers, they will not do much for you. You could try the person that sold it to you to see if they will refund your money or deal with Rogers. As a last resort, try printing out the result of the warranty check and see if Bell will send it off to RIM for you.

    http://www.rogers.com/web/Rogers.por...OfWarranty_1_1
    12-21-11 03:03 PM
  20. lalido's Avatar
    The phone is still under warranty

    I tried to deal with rogers and bell to no avail

    Looks like the only option i have is to make the phone work but it doesnt seem to be a hardware problem so there has to be a way to fix whatever the issue is?

    I would really appreciate any help
    12-21-11 03:15 PM
  21. lalido's Avatar
    It depends on the situation. for example the scroll does not work in the main options menu but in the sub menu's it works.

    On the main menu, i can scroll between the icons but cannot scroll onto the notification bars above.

    it really is bizar!

    With the touchscreen i can access everything flawlessly
    12-21-11 03:31 PM
  22. lalido's Avatar
    Its not only in the main menu, for example, if a pop up to delete an application only after a restart the trackpad will not allow me to highlight the other option
    12-21-11 11:30 PM
  23. lalido's Avatar
    So this is wierd:

    When i hold down the alt or shift keys I can move the cursor normally and i also discovered that i can no longer hold the ALT key and press other keys to get the alternate keys, i have to press the ALT, release it and press the other key to get the symbol. Same thing applies with the SHIFT key to get Upper case letters!

    Hope this clears up the problems for everyone!
    12-22-11 09:15 AM
  24. robsteve's Avatar
    Sounds like you have a bad keyboard.

    Ask your Bell store if they have a store that does repairs and could fix it for you. If it isn't water damage, they may even just put the repair though warranty to RIMM. Print out the imei check that shows the in service date for proof of warranty.

    If this doesn't work, there is another thread here regarding replacement keyboards. You need to get the complete unit, which will have the trackpad in it.
    12-22-11 09:24 AM
  25. lalido's Avatar
    Called Bell, they cant repair a rogers phone and rogers wont repair without an active rogers account.

    looking into replacing it myself.
    Anybody tried this succesfully? and where did they get the parts from?
    12-22-11 12:22 PM
34 12
LINK TO POST COPIED TO CLIPBOARD