09-09-11 12:02 AM
27 12
tools
  1. anon(153966)'s Avatar
    I returned my 9900 from T-mobile. Why?

    1. Trying to delete emails and it doesn't always work. Sometimes you have to do a battery pull...

    2. Email setup\edit signature etc does not work. Not via the device of T-Mobile BIS. RIM and T-Mobile are sending users from pillar to post, yet no resolution.

    3. Browsing webpages and the browser would simply close. Even after clearing the cache, same thing.

    4. Pressing ESC will sometimes not do that, it would take you to the task manager window. Multiple users having this issue

    5. For a $600 device from T-Mobile, I'll just wait till AT&T releases it, simply no need dealing with these issues. My iPhone will have to suffice for now.

    Note that I'm a true gadget user and won't comment too much on a device unless I've tested it myself. But, the above issues don't seem to be resolvable with leaked OS', hence it has been [well 7th Sep] returned to T-Mobile. When AT&T release their version, I'll try again...

    Have you had similar issues?
    Vihzel and Chrisy like this.
    09-06-11 09:55 PM
  2. satanberry's Avatar
    I could not validate one of my gmails account with my Rogers device running stock .261 but I upgraded to .317 and have never had a single issue since. Now running .353 and it's better than ever. Media player is louder and battery life is definitely better albeit still less than 9780.
    09-06-11 10:04 PM
  3. grover5's Avatar
    That sucks OP. My 9900 hasn't had any of those issues. I hope it keeps working well. It is a great device but I'm sure not so much if it is being buggy.
    09-06-11 10:13 PM
  4. drfever's Avatar
    Looks like you either got the first one made on a Monday morning or last one made on a Friday. Sorry to hear but with so many devices, one or two will be flops.

    Posted from my CrackBerry at wapforums.crackberry.com
    CavemanOOGA likes this.
    09-06-11 11:32 PM
  5. HaTaX's Avatar
    That stinks, sorry you had so many issues, I've actually had had none of the ones you described. Did you start fresh with the 9900 or did you do a device move using the app on the blackberry or desktop manager?
    09-06-11 11:59 PM
  6. mhw100's Avatar
    Why not just replace it if the unit is malfunctioning...are you out of the return policy period?
    09-07-11 01:41 AM
  7. Core_Frequency's Avatar
    I had problems with email settings with my t-mo 9900, it would not connect to the server. It started back up today... it seems like a t-mo problem. The only problem is now is that my gmail calendars/contacts don't sync ( 3 gmail accounts, 2 personal and 1 university issued). Not sure if it's t-mo or bis...

    Everything else has been running so smooth, even on the stock os. The only reason why I changed it was to add arabic. Improved battery doesn't hurt either
    09-07-11 03:02 AM
  8. belfastdispatcher's Avatar
    I had problems with email settings with my t-mo 9900, it would not connect to the server. It started back up today... it seems like a t-mo problem. The only problem is now is that my gmail calendars/contacts don't sync ( 3 gmail accounts, 2 personal and 1 university issued). Not sure if it's t-mo or bis...

    Everything else has been running so smooth, even on the stock os. The only reason why I changed it was to add arabic. Improved battery doesn't hurt either
    Sometimes you have to delete the gmail account and add it again to get those syncing, if you just resend service book that were set up for another device will not work.

    Posted from my CrackBerry at wapforums.crackberry.com
    Core_Frequency likes this.
    09-07-11 03:28 AM
  9. radlink14's Avatar
    If you really liked the device do an exchange. My 9900 from tmobile was dying too fast, even after power cycling it and trying 2 different os versions! But did an exchange and the new one has lasted me 2 days! The keyboard has LED bleed but it's all good it looks kinda cool lol
    09-07-11 03:38 AM
  10. Core_Frequency's Avatar
    Sometimes you have to delete the gmail account and add it again to get those syncing, if you just resend service book that were set up for another device will not work.

    Posted from my CrackBerry at wapforums.crackberry.com
    Yeah I tried restoring my 9780 back up and it was a disaster... So I deleted them and added them again it didn't help . I will will try it again tomorrow after class, t-mobile's email settings server was not working for the past few days... hopefully they fixed the problem
    09-07-11 04:25 AM
  11. rrrebo's Avatar
    That sucks, Navi, but you might be better off for now. I understand T-Mo was/is having some issues with e-mail registration on the back end. The 9900 is a good device. I hope you get the chance to go back to it.
    09-07-11 05:59 AM
  12. o4liberty's Avatar
    I have the 9930 and none of those issued here. I am seeing more issued on the 9900 than the 9930 here on the forums. I guess the OS is different on both of them.

    Sent from my BlackBerry 9930 using Tapatalk
    09-07-11 07:22 AM
  13. belfastdispatcher's Avatar
    I find the best way to get started with a new blackberry is to start fresh as if it was your first blackberry and set everything up from scratch. Wipe and start again.

    If you're not happy take it back and get something else, no point spending 2 years with a device you don't like.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-07-11 07:51 AM
  14. anon(153966)'s Avatar
    I agree, I started fresh, since I was coming from an iPhone. Plus, I even if I have current BlackBerry, I don't use the 'switching' device option. I like a 'clean install'...

    I'm this ---- close to going back to Verizon!
    09-07-11 07:56 AM
  15. willtothewong's Avatar
    I too am having issues with gmail on my 9930 on Verizon. I hope to get my issues sorted out before I am out of my return window soon. My Droid X handled my Gmail way better than my 9930. But that's just Gmail. I know someone who's Yahoo accounts sync just fine. Very strange.
    09-07-11 10:00 AM
  16. lazerus's Avatar
    The 99xx is still in beta. We are the testurs.
    09-07-11 01:03 PM
  17. Core_Frequency's Avatar
    Sometimes you have to delete the gmail account and add it again to get those syncing, if you just resend service book that were set up for another device will not work.

    Posted from my CrackBerry at wapforums.crackberry.com
    Just came back from the university and deleted and re-setup my email accounts and now everything is working like it should

    Thanks
    09-07-11 05:24 PM
  18. zeelob's Avatar
    Email setup from the 9900 is now working on T-Mobile. No longer getting message saying that the server cannot be found. Switched from AT&t to T-Mobile to get the 9900
    09-07-11 07:48 PM
  19. papped's Avatar
    The 99xx is still in beta. We are the testurs.
    Most of the issues sound like Tmobile service/registration issues, not 9900 issues...
    09-07-11 07:56 PM
  20. anon(153966)'s Avatar
    Good point Papped. Seems like things might be leveling out now.

    But, does anyone still have an issue deleting emails from it? Sometimes you'd delete an email, yet, it would STAY on the device. In GMail online, it would be in the 'Trash'.

    Weird, no?
    09-07-11 09:18 PM
  21. Kontakt7's Avatar
    Probably just got a dud. My brother had to return one for a touchscreen problem and another for wifi radio issues. I haven't had any problems with mine; knock on wood.
    09-07-11 10:08 PM
  22. Core_Frequency's Avatar
    Well I can't fully blame t-mobile for my problems... I didn't give my BIS account time to fully kick in before I added my emails... I tried to add them right after I got off the phone with CS haha
    09-08-11 02:51 AM
  23. otacon#AC's Avatar
    I have a Verizon 9930 and have not experienced any of the issues the OP has had. When any new device comes out there's going to be some faulty ones unfortunately. I've been lucky in that I've never had to return any BB for defects.
    09-08-11 03:31 AM
  24. otacon#AC's Avatar
    The 99xx is still in beta. We are the testurs.
    Totally disagree. With any new device there's going to be defects. Many of the issues I've seen posted are carrier specific not hardware specific. People aren't going to post "I have no issues with my 99XX". They are going to post when they have issues.

    People who have a PlayBook are beta testers.
    09-08-11 03:42 AM
  25. danielordonez's Avatar
    have you bought it with or w.o contract?
    09-08-11 06:28 PM
27 12
LINK TO POST COPIED TO CLIPBOARD