1. blackberryorraspberry's Avatar
    Hi, I just got a Bold 9900 about 2 and a half months ago. The keyboard has lately been messed up for me. For example, when I press alt and 'm' for a period, I'll still get only an m. My 'p' and 'a' keys generally need to be pressed more than once to work, as well as the enter and backspace keys. The keyboard lacks proper responsiveness overall. I was wondering if anybody else had this problem and knew if there was a quick fix. I don't think I lack application memory as when I restart my phone I have a full 100MB.

    Thanks everybody in advance!
    06-05-12 10:56 PM
  2. iPhone4iPad's Avatar
    I suggest replacing your keyboard.
    I once myself had this similar experience, but yours didn't press, whereas my buttons would press the button next to it.
    For eg. if i pressed N, NM would come up infinite times.
    And sometimes randomly they used to press when locked.
    -.-
    I opened the phone, found a lot of dust in the keyboard, cleaned it, ordered a BRAND new Keyboard from eBay, and after that nothing so far!
    *fingers crossed* though i do have another problem with this *****...
    Good luck!
    06-06-12 01:16 AM
  3. dictoresno's Avatar
    if its that new, its under warranty so try to get a new one through your carrier. if not, see the link in my sig. you may need to do something similar for your phone.
    06-06-12 03:18 AM
  4. blackberryorraspberry's Avatar
    Thank you for your help. It's still under RIM's warranty, so I'll probably get it fixed/replaced.
    Thanks again!
    06-06-12 09:45 AM
LINK TO POST COPIED TO CLIPBOARD