1. Procterboy's Avatar
    hey guys, im getting quite frustrated again with my Bold regarding battery life (came from a 9700). whenever i charge it, i notice it almost never chagres past 85-90%. also the battery has to be charged 2-3 times daily and im not a hardcore user, i have a playbook for that kinda usage . no there are not a lot if apps running in the backround.

    any ideas what to do? im getting tired of this. i paid 385$ for this phone ON A CONTRACT and the battery life frankly sucks along with a few other issues which are not right for Rims flagship phone.

    any ideas? should i swap out the phone?

    thx
    01-05-12 02:32 PM
  2. 85_305's Avatar
    Update it! Mine will sometimes do that... Sometimes stopping at 85%. If you unplug it then plug it back in it will finish charging. Don't know why it does that, but occasionally it does.

    And fyi, since I've updated to os .579 I have found all my co workers either recharging in the office/on the run, or leaving the office with their iphones/droids in the single-digit percentages of battery life life. Whereas my 9900 nearly always has 40ish percent battery left when I leave.

    Posted from my CrackBerry at wapforums.crackberry.com
    01-05-12 03:12 PM
  3. Procterboy's Avatar
    nice, ill try that soon, i left my computer in Canada tho lol
    01-05-12 03:28 PM
  4. emirozmen's Avatar
    I advise you to update or reload your OS
    01-05-12 04:20 PM
  5. Procterboy's Avatar
    I will when I have time lol
    01-05-12 06:40 PM
  6. 85_305's Avatar
    Damn were you in Buffalo when you wrote that? I was busy and couldn't check the forums, but if you were around Buffalo I woulda invited you to borrow a charger or something and helped you update it.
    01-05-12 08:51 PM
  7. ignites's Avatar
    hey guys, im getting quite frustrated again with my Bold regarding battery life (came from a 9700). whenever i charge it, i notice it almost never chagres past 85-90%. also the battery has to be charged 2-3 times daily and im not a hardcore user, i have a playbook for that kinda usage . no there are not a lot if apps running in the backround.

    any ideas what to do? im getting tired of this. i paid 385$ for this phone ON A CONTRACT and the battery life frankly sucks along with a few other issues which are not right for Rims flagship phone.

    any ideas? should i swap out the phone?

    thx
    what kinda charger are u using?

    are you looking at the battery via an app. some apps are inaccurate.
    01-06-12 12:09 AM
  8. Procterboy's Avatar
    I'm using the charger block that came with the phone and a usb to mini usb cord
    (Aftermarket Sync cord) however no difference between the original sync cord

    Posted from my CrackBerry at wapforums.crackberry.com
    01-06-12 08:22 AM
  9. dadathepanda's Avatar
    My 9930 does the same sometimes only it stops at 95 % or 100% with the flash symbol on the battery and to get it to finish and the plug symbol to appear I have to unplug the micro USB and plug it back in. Don't know what's causing this issue but it has gotten better since I first got the phone.
    01-06-12 12:50 PM
  10. wolfee48's Avatar
    Mine did this prior to 7.1 when I use the OEM charger provided (little cube). It is not my primary charger though. My primary chargers are from my 8530,9550, and 8830 (mini to micro adpater used).
    01-06-12 01:16 PM
  11. chaddeus's Avatar
    Easy solution. unplug and plug it back again.

    - Charles
    01-06-12 02:13 PM
LINK TO POST COPIED TO CLIPBOARD