1. rubiohiguey's Avatar
    I did some battery testing with exact battery usage information from meterBerry, on 7.1.0.267 (9900)

    3G heavy usage (click, load, click, load, click, load) - 1% / min (100 minutes on fully charged battery)
    EDGE heavy usage - 0.75% / min (133 minutes on fully charged battery)
    Wifi heavy usage - 0.5% / min (200 minutes on fully charged battery battery)

    Tried both in Opera Mini and Native browser 7.1 and with facebook app, with roughly the same results.

    This data seems really really BAD! I am starting to think there is something bad with the phone or the battery...BUT...I did GSM call testing and get exactly 18 minutes for 5% of battery juice on 3 bars (equals 360 minutes - 6 hours) of talk time, which roughly corresponds to the device talk time as indicated by phone specs.

    Opinions?

    Can anybody post their 3G "heavy browsing" battery stats? (e.g. 5 minutes of heavy browsing - no reading, just clicking and loading).
    03-02-12 10:44 AM
  2. emirozmen's Avatar
    You have a defective battery or device.
    03-02-12 11:48 AM
  3. nd1983's Avatar
    yes battery or you have other stuff loaded in the background. i spent about 3 hours last night surfing on 3g and still had well over 50% left
    03-02-12 11:49 AM
  4. MrChiezy's Avatar
    Bro, I have exact the same problem!
    And I don't know if its the new OS or something else.
    03-02-12 03:16 PM
  5. Smartie020's Avatar
    Same here. Im on my third Bold and it was the same on any of those phones so I guess it must be the battery.

    Also unplugging the phone from the charging cable my battery drain rate is like 1,5%/h, which is ok. But as soon as I start to use the phone, the consumption, even when I dont use the phone for an hour and all apps are closed, battery draining stays on an higher than before...
    03-02-12 03:42 PM
  6. MrChiezy's Avatar
    But is it because of the new OS or our batteries became defect?
    I just deleted all my 3 party apps except ubersocial and whatsapp. (Ubersocial on manul.)

    Hope this will help, so jealous with people who have a good battery life.
    03-02-12 04:11 PM
  7. deezy87's Avatar
    Same here. Im on my third Bold and it was the same on any of those phones so I guess it must be the battery.

    Also unplugging the phone from the charging cable my battery drain rate is like 1,5%/h, which is ok. But as soon as I start to use the phone, the consumption, even when I dont use the phone for an hour and all apps are closed, battery draining stays on an higher than before...
    It has happened to me as well. I checked at work, maybe 3 days ago. Posted in a thread, reply back was that you shouldn't let your phone be plugged into a charger all day. Got in a grp chat and the drainage was like 8.64%. It's at about 2 at the moment. It seems to fluctuate, that's just a guess though.
    03-02-12 06:13 PM
  8. rubiohiguey's Avatar
    I love my BB9900 and hate the battery! As I wrote above, it sucks battery at 1% per minute when 3G browsing (any 3g activity), and edge is only "slightly" (pun intended) better. Talk or standby is OK, it's the DATA. it even sucks battery at 4% per hour when on standby on wifi with no gsm radio turned on and doing NOTHING...just sitting beside the router! I love it and hate it! I hope Orange Dominicana will change my device, I have had it for 3 days now and they say something about 7 day swap.

    I compared battery usage today to my old Bold 9000, and what a difference. Bold 9000 sucked 4% of battery while 15 minute heavy browsing. Bold 9900 sucked 15% the same 15 minute heavy browsing! Even 20% battery capacity difference between 9000 and 9900 does not account for that! 9900 is giving me 20% of the 3G usage time than 9000 was giving me. 9900 has brightness down to 10, timeout to 10 seconds, GPS/localization off. No apps running besides BBM. Something is rotten in the state of Denmark!
    Last edited by rubiohiguey; 03-02-12 at 08:40 PM.
    03-02-12 08:32 PM
  9. rohit1767's Avatar
    It definitely appears to be a problem with the 7 OS in general and the radio modules. The 7.1 upgrade (still trying to find the right build?? ) is apparently supposed to fix this issue.

    3G only - idle device -> 8-10% battery drain / hr.
    2G only - idle device - 0-1% battery drain / hr.

    All I ask of my device is to take me through one 1 work day and having to charge only at nights. Too much to ask of the latest BB Bold 9900, I guess?
    03-14-12 10:29 AM
  10. audio_engr's Avatar
    3G heavy usage (click, load, click, load, click, load) - 1% / min (100 minutes on fully charged battery)
    wow !! I'd keep the charger in my pocket or better, plugged-in the device ..

    all in all .. I still love the 9900 and its speed ...
    03-14-12 10:35 AM
LINK TO POST COPIED TO CLIPBOARD