1. quant_BB's Avatar
    Hey guys,

    So, I've updated to the latest .474 and it seems that my battery life got worse (I am coming from .261). It idles about 5% an hour. Also, when I check the battery info, it always shows me in 5% increments. Like, first 100%, then 95%, then 90% an so on.

    Should I reinstall? or go back to .261? or just wait till 7.1?

    Thanks.
    11-06-11 06:39 PM
  2. jeffrey1027's Avatar
    go back if you don't like this build. did you do a clean wipe before installation? remember the real battery life shows after a day or two and a few batt pulls
    11-06-11 06:40 PM
  3. UrbanGlowCam's Avatar
    Hey guys,

    So, I've updated to the latest .474 and it seems that my battery life got worse (I am coming from .261). It idles about 5% an hour. Also, when I check the battery info, it always shows me in 5% increments. Like, first 100%, then 95%, then 90% an so on.

    Should I reinstall? or go back to .261? or just wait till 7.1?

    Thanks.
    From what I hear, 474 has noticeably improved battery life for users. There could be several factors affecting your results.

    For one, you could be in an area with poor reception which will drain battery more quickly. Another thing is that you should give it a few days for settling before really judging. I would say after 2-3 full days of cycling with charges should give you a good impression.

    If you don't see better results after, I would recommend either reinstalling the OS or reverting back to the OS that worked better prior.

    Good luck!
    quant_BB likes this.
    11-06-11 06:42 PM
  4. quant_BB's Avatar
    go back if you don't like this build. did you do a clean wipe before installation? remember the real battery life shows after a day or two and a few batt pulls
    Um, no, not really. I just updated it via uploader. I guess when you say clean wipe, you mean like to completely erase OS first (using swiss knife or something) and then install?

    Thanks.
    11-06-11 06:48 PM
  5. quant_BB's Avatar
    From what I hear, 474 has noticeably improved battery life for users. There could be several factors affecting your results.

    For one, you could be in an area with poor reception which will drain battery more quickly. Another thing is that you should give it a few days for settling before really judging. I would say after 2-3 full days of cycling with charges should give you a good impression.

    If you don't see better results after, I would recommend either reinstalling the OS or reverting back to the OS that worked better prior.

    Good luck!
    Thanks.
    Yeah, that's true, reception in my crib sucks. sometimes it can't even find the signal. But yeah, OK I will give it few days and see what's up.

    Do you think it's weird though that the battery discharges by 5% increments? do you guys have the same thing? It never shows like 92% or 64%...
    11-06-11 06:50 PM
  6. Phill_UK's Avatar
    Do you think it's weird though that the battery discharges by 5% increments? do you guys have the same thing? It never shows like 92% or 64%...
    Nope... if you're taking those figures from the Device and Status Information screen, then it's always been that way.

    If you want a more accurate indication of battery life, then install a dedicated battery monitoring app like MeterBerry.

    Posted from my CrackBerry at wapforums.crackberry.com
    quant_BB likes this.
    11-06-11 06:55 PM
  7. quant_BB's Avatar
    Nope... if you're taking those figures from the Device and Status Information screen, then it's always been that way.

    If you want a more accurate indication of battery life, then install a dedicated battery monitoring app like MeterBerry.

    Posted from my CrackBerry at wapforums.crackberry.com
    OK, great, thanks. For some reasons I thought that it was not the case before.

    I will give it a few days and report back.
    UrbanGlowCam likes this.
    11-06-11 06:59 PM
  8. quant_BB's Avatar
    well, it's been six hours and I am at 40% battery with light use. FML

    Do you guys install those battery optimization apps? do they help?
    Thanks.
    11-06-11 11:05 PM
  9. djnick's Avatar
    give it a few days to settle in. Also make sure you dont have apps polling in the background like twitter, fb, social feeds etc. I have all those uninstalled and deleted. They are battery killers
    11-07-11 01:24 AM
  10. Jake Storm's Avatar
    I'm getting better battery life with .474
    11-07-11 02:21 AM
  11. quant_BB's Avatar
    Thanks guys.

    Yeah, it's little bit frustrating. It lasted from 6am to 3pm today (Shanghai time). ugh. hope it will get better
    11-07-11 02:47 AM
  12. Legal Eagle's Avatar
    go back if you don't like this build. did you do a clean wipe before installation? remember the real battery life shows after a day or two and a few batt pulls
    Why should we do battery puls after installing a new OS ???
    11-07-11 03:48 AM
  13. UrbanGlowCam's Avatar
    Why should we do battery puls after installing a new OS ???
    It's a good idea to do a battery pull occasionally to clear up the software and anything running incorrectly. It usually clears up memory and much of the unnecessary processing running in the background. It's usually just a good idea to do a battery pull shortly after an OS insatll to ensure all applications are installed correctly and there are no more hard restarts required.

    I think a lot of it is just for peace of mind. It doesn't hurt and you will likely only benefit from it.
    11-07-11 04:59 AM
  14. lostOzone's Avatar
    When you install a new OS the system reboot from scratch! So there is no need to clear up a memory that is supposedly already cleared. But many have reported that a battery pull change the battery meter reported. So there is at least one reason to battery pull.
    11-07-11 05:33 AM
  15. rexrim's Avatar
    do more battery pull after installing new os bro..
    my battery was superb on this new official os.474 by wind...
    11-07-11 06:13 AM
  16. CanuckSoldier's Avatar
    Thanks.
    Yeah, that's true, reception in my crib sucks. sometimes it can't even find the signal. But yeah, OK I will give it few days and see what's up.

    Do you think it's weird though that the battery discharges by 5% increments? do you guys have the same thing? It never shows like 92% or 64%...
    I'm in the same boat, very poor reception in my area, and on top of that I have it connected to my router when ever in range. So to be realistic 474 is not any worse that any other build for battery life for me. But software can't make up for the fact that the towers are too far away

    CS
    11-07-11 06:23 AM
  17. harlay's Avatar
    some say leak .440 is the best os for battery life
    but i'm using 474 i can barely tell the difference
    11-07-11 09:03 AM
  18. knowledge_6's Avatar
    battery life seems to be the same for me with .440 and .474...

    with very light usage during the day (mostly weekends cause i am always running around doing stuff) i get 2.6% discharge rate...

    with heavy usage i get around 5.5% discharge
    11-07-11 09:55 AM
LINK TO POST COPIED TO CLIPBOARD