1. cmbaus's Avatar
    I upgraded my bold 9000 to 9900 today. I like the new phone, however I found out that I can not get email, using BBM or AppWorld through WIFI anymore. Internet works though. I have a BES plan but some time I travel internationally. When I am roaming I turn my data off and use WIFI to get my emails. My Bold 9000 works fine for WIFI. Maybe I have to go back to 9000. This sucks. Is there a way to get around this?
    12-02-11 10:35 PM
  2. Fubaz's Avatar
    have you had this phone properly activated and provisioned on your BES?
    if so, start there.

    if you want to just be hasty, keep pouting, get mad and go back to your 9000... if not talk to your IT department.
    shaleem likes this.
    12-03-11 12:53 PM
  3. cmbaus's Avatar
    I have the new BB9900 phone activated and everything works fine through BES data plan. I just do not understand why either RIM or ATT took the "email and BBM over WIFI " feature away from the new bold 9900. This was very useful while you are roaming internationally and it worked nicely on bold 9000. I am curious if this is some setting I need to do on 9900 to get it working. Any help?
    12-03-11 04:07 PM
  4. SwitchBeach's Avatar
    They didn't "take it away". BBM and Email will work over WiFi if you have an active BlackBerry Data Plan.

    You need to make sure that you have Data turned ON. And Data OFF while Roaming. And WiFi ON.
    12-03-11 04:19 PM
  5. Gehangin's Avatar
    I have a similar problem, but only on certain networks. I'll explain:

    My sim and BIS plan is from Cellcom Israel. I have "Data Services" set on ON and "While Roaming" set to OFF. "Network Selection Mode" is set to "Automatic".

    When roaming in the States and the BB picks up AT&T - the home screen top says "AT&T - Cellcom". When roaming in the UK and the BB picks up Orange - the home screen top says "Orange - Cellcom". In each instance the "Mobile Network" info page reads the same as the home screen for the connected roaming network. Data doesn't come through, as set per above, unless I am on a WIFI network, in which case the WIFI network name also appears on the home screen and then BIS does work.

    Here is the weird part: When in the States and the BB picks up "T-Mobile - Cellcom" (as displayed on the home screen) IT DOES ALLOW BIS DATA - even though data roaming is set to OFF, per above. What is peculiar is that on the 'Mobile Network" page, the connected network is displayed as "Cellcom" (without the T-Mobile prefix) - so the BB thinks I am on my home network - which I am not. If I set "Data Services" to OFF - then I get no BIS when I am connected to WIFI (so I can confirm that what is happening to the OP is happening with me as well).

    So I see two problems here:
    1) If "Data Services" is set to OFF on the "Mobile Network" page - then a WIFI connection will not give you BIS.
    2) The 9900 is not always correctly discerning Home networks from Roaming networks (in my case, with T-Mobile US and Cellcom).
    12-05-11 02:11 PM
  6. MB64's Avatar
    my problem is hat it wont recognize my modem...it will once i reboot my router and will work for a few minutes, but then it will drop again and when you try to connect it says that it doesnt recognize the IP address
    12-05-11 03:17 PM
  7. cmbaus's Avatar
    I have all the proper settings and the right data plan. To follow up I spent 6 hours with AT&T and RIM support. No one could figure out why. Finally the RIM guys suggested me to do a forced wipe on the phone to restore to factory settings. Once I did that everything started working. Good news is RIM did not take that away. Oh well I got it working finally.
    12-05-11 06:56 PM
LINK TO POST COPIED TO CLIPBOARD