1. adicktuz's Avatar
    Didn't quite noticed it, but when I was tweeting. A white screen popped up and said JVM 502 error, I don't remember if it was 502 but I'm sure it was a JVM error. But after 2-3 seconds it disappeared.

    Don't know what caused it. All I did today was, downloaded Foursquare (sucks anyway), upgraded BeBuzz (fail upgrade + $1.50 charge) and Fruits & Ninja.

    It got me all worried and deleted Foursquare right away, didn't like it anyway.

    But now, it seems that my phone is working fine as usual. Should I be worried about it?

    *Also, has anyone upgraded their BeBuzz yet? It seems like that BBM's LED is not working. I've checked all my other notifications and they're all working except for BBM.

    Thanks!
    12-15-11 09:08 AM
  2. adicktuz's Avatar
    Why am I getting a JVM Error? I got again just now, when the phone was idle. Screen was white again and with JVM error on it, and a continue button below it.
    12-15-11 11:12 AM
  3. greggebhardt's Avatar
    I would back up your phone right now as it is only a matter of time.
    12-15-11 11:20 AM
  4. adicktuz's Avatar
    Yea, I'll back it up now, and also downloading the .540. I'm still waiting for the JVM error to pop up, I can't remember what error number was it.
    12-15-11 11:28 AM
  5. Mel25's Avatar
    java error 545 this is happening to my phone right
    now plz help!
    12-15-11 11:41 AM
  6. manofice1's Avatar
    just backup, wipe and reload the os
    12-15-11 01:10 PM
  7. Mel25's Avatar
    just backup, wipe and reload the os
    Didnt know i could back up while in this screen.

    Man my phone is f****ked up right now !!
    12-15-11 01:15 PM
  8. manofice1's Avatar
    it had to have been something you installed
    12-15-11 01:19 PM
  9. Mel25's Avatar
    it had to have been something you installed
    It probably was i dont deny that.

    I'm so frustrated because i never backed up my 9900.

    So i remembered i back up my 9780 so u guessed it. I forgot to just check off address and text messages so now all my 9780 bs problems are on my 9900.

    I cant even move my icons.


    Im tired im so tired of this phone. Yes i know the last isssue is my fault because i put the 9780 data on my phone but my head is about to explode.
    12-15-11 01:33 PM
  10. sleepngbear's Avatar
    It probably was i dont deny that.

    I'm so frustrated because i never backed up my 9900.

    So i remembered i back up my 9780 so u guessed it. I forgot to just check off address and text messages so now all my 9780 bs problems are on my 9900.

    I cant even move my icons.


    Im tired im so tired of this phone. Yes i know the last isssue is my fault because i put the 9780 data on my phone but my head is about to explode.
    Sorry to hear about your troubles. As soon as you got the JVM error, you were pretty much toast. That usually means a critical corruption of some kind that you might be able to recover from with a full wipe and OS reload, but that's an iffy proposition at best and does not guarantee you won't see it again. Your carrier should replace the phone for you.
    12-15-11 02:13 PM
  11. gordonzhao's Avatar
    I've seen in some previous builds foursquare caused crashes, but in recent builds it's been fine. The most recent conflict with OS builds that I've come across in the forums, not myself, is BeBuzz. I think it's the program, try reinstalling and not installing BeBuzz and see if you experience the same crash.
    12-15-11 07:42 PM
  12. Czar_of_Berry's Avatar
    BeBuzz...

    Posted from my CrackBerry at wapforums.crackberry.com

    Posted from my CrackBerry at wapforums.crackberry.com
    12-15-11 08:07 PM
  13. rdef's Avatar
    Kind of like being almost pregnant isn't it? Either the device is bricked or it isn't, right?
    12-15-11 11:22 PM
  14. sbx9900's Avatar
    BeBuzz...

    Posted from my CrackBerry at wapforums.crackberry.com

    Posted from my CrackBerry at wapforums.crackberry.com
    What builds is BeBuzz not compatible with. I'm on .540, and I just installed BeBuzz v5 yesterday. Am I expecting trouble here?
    12-16-11 09:28 AM
  15. StumptownBold's Avatar
    I'm on a 9930, running .374. Although I had BeBuzz on my previous model (8330), I ended up not transfering to my new 9930. I just bought the newest version of BeBuzz and have had no problems at all.
    12-16-11 09:37 AM
  16. Mel25's Avatar
    All is well with my9900 for now.

    I just delete all the data i put on my phone from my 9780 the used my tmobile back up.
    12-16-11 09:41 AM
  17. sleepngbear's Avatar
    Good to hear. Hopefully it was just a data issue, but back up often anyway!
    12-16-11 10:08 AM
  18. adicktuz's Avatar
    Guess I won't be seeing that JVM error anymore. Backed up my phone and installed a newer OS.

    But it seems .540 is a battery sucker. I get discharge rates of 18%-24%/hour even on idle. I used to get 2%-10%/hour before on .503.

    And all application settings the same on both OS.
    12-16-11 10:51 AM
  19. adicktuz's Avatar
    I was wrong. I did see the JVM error again, this time it was JVM error 520. And it's not even on the BlackBerry site.

    Error messages: BlackBerry Device Software - BlackBerry Bold 9900/9930 Smartphones - User Guide - BlackBerry Bold Series - 7.0

    Error popped up when I launched this game Angry Pigs (bought from App World). I pressed the back button and the white screen is gone. Tried to launch the game again and it worked.

    It's a bit disappointing that you have no clue what the **** is wrong with your phone. I just installed a new OS but that error showed up again.

    You guys have any clue what's this JVM Error 520? Or what's causing it?

    Here are the apps installed on my phone.
    BeBuzz 4.0.85
    Fruits and Ninja
    BerryWeather
    Bejeweled
    MeterBerry
    TuneIn Radio Pro
    Screenshot
    Pandas vs Ninjas
    BatterySaver Pro
    Speedometer
    Shazam
    Angry Pigs

    All these apps seem to work fine before I had the first JVM error last night, which I think was caused by either Foursquare or BeBuzz 5.0.

    Do I need to wipe my phone and reload the OS again? Since what I did was, backed up & reloaded the OS without wiping it.

    Thank you!
    12-16-11 12:55 PM
  20. sleepngbear's Avatar
    I was wrong. I did see the JVM error again, this time it was JVM error 520. And it's not even on the BlackBerry site.

    Error messages: BlackBerry Device Software - BlackBerry Bold 9900/9930 Smartphones - User Guide - BlackBerry Bold Series - 7.0

    Error popped up when I launched this game Angry Pigs (bought from App World). I pressed the back button and the white screen is gone. Tried to launch the game again and it worked.

    It's a bit disappointing that you have no clue what the **** is wrong with your phone. I just installed a new OS but that error showed up again.

    You guys have any clue what's this JVM Error 520? Or what's causing it?

    Here are the apps installed on my phone.
    BeBuzz 4.0.85
    Fruits and Ninja
    BerryWeather
    Bejeweled
    MeterBerry
    TuneIn Radio Pro
    Screenshot
    Pandas vs Ninjas
    BatterySaver Pro
    Speedometer
    Shazam
    Angry Pigs

    All these apps seem to work fine before I had the first JVM error last night, which I think was caused by either Foursquare or BeBuzz 5.0.

    Do I need to wipe my phone and reload the OS again? Since what I did was, backed up & reloaded the OS without wiping it.

    Thank you!
    If you got the same error again, I think it's a hardware issue and a wipe or OS update isn't going to help. I'd look into getting that thing replaced ASAP.

    If you installed the last OS with Apploader, it basically wipes the device clean and reinstalls your apps and data after the new OS is loaded anyway.
    Last edited by 18to7fiddy; 12-16-11 at 01:02 PM.
    12-16-11 01:00 PM
  21. adicktuz's Avatar
    I don't think I got the same error again. The first 2 errors I got was 502, not sure though but I'm sure it wasn't 520 before.

    But do you think it's really a hardware issue? I didn't get my phone from my carrier, I bought it unbranded. I do have a 2-year warranty from BlackBerry though.

    Should I try to reload an OS again? Or just have my phone replaced right away?

    It's getting frustrating now.
    12-16-11 01:07 PM
  22. axllebeer's Avatar
    I've had my Sprint 9930 for a whole day now and I thought I nuked it already. I downloaded the Sprint radio app and even though it worked, prompted me that at the end of December it was being discontinued. So I just deleted it again. On the reboot, it got 3/4 of the way then would freeze. I did this 6x's with same results never booting up fully. After several combinations of booting it on the charger, battery door off then on again, then took my SD card out, still no luck. Then I pulled the GSM SIM card and tried again booted right up. Faulty card perhaps? Any ideas? I haven't been out of the country in 10 yrs so not worried about that. But still going to Sprint to get a replacement as I bought the phone, so it should be fully functional.
    Last edited by axllebeer; 12-17-11 at 12:13 AM.
    12-17-11 12:10 AM
  23. adicktuz's Avatar
    Downgraded OS back to .503, .540 drains too much for me. I tried it yesterday and .540 only lasted for 6 hours with maximum usage.

    Also seen the JVM error 520 popped up again, so I decided to go back to .503. Been tweeting to @BlackBerryHelp and @BlackBerry about JVM error 520, and they don't answer.

    Talk about customer service.
    12-18-11 12:46 PM
  24. gordonzhao's Avatar
    Downgraded OS back to .503, .540 drains too much for me. I tried it yesterday and .540 only lasted for 6 hours with maximum usage.

    Also seen the JVM error 520 popped up again, so I decided to go back to .503. Been tweeting to @BlackBerryHelp and @BlackBerry about JVM error 520, and they don't answer.

    Talk about customer service.
    Get on the .585/.503 hybrid!
    12-20-11 01:06 AM
LINK TO POST COPIED TO CLIPBOARD