1. viking87's Avatar
    Hi everybody...

    So I have loved my new 9930, but as of a couple days ago I have ran into a really bad problem... My keyboard has had a stroke. Every time I press a p,or an x, I get xp. Every time I press an e it capitalizes, every time I press b or enter I get a B and then an enter, and a couple more but you get the point. Anyone else have any troubles? I haven't put on a new os, but honestly I don't see how it could be a software issue, since it has been working well the first couple weeks. Thanks all.
    09-15-11 12:58 AM
  2. balenax's Avatar
    any contact with water or some sticky liquids maybe ?
    09-15-11 02:23 AM
  3. viking87's Avatar
    You know, that's what my mind went to b/c it does sound like a water problem... but no, I have been way too careful with it and it hasn't even seen moisture in the air... when I first noticed it, I had picked up the phone after working (I left it in a cabin, no sun or heat damage) and it was just sitting in about 80 degrees with no humidity as I live in a high desert climate... so I really don't see how water could've been at work here... and no I didn't move my phone from a really cold place to a hot place either, so no condensation.

    Anyhow, I'm just wondering if anyone thinks it's a chance it could be software, cuz I'm going to call tomorrow to see if I can get it replaced.

    Edit to say that another reason I don't think it could be water damage is because for the first few times, a battery pull would fix it for the rest of the day. Now a batter pull fixes it for only a minute or so, but still.. if it was a short, it should be damaged and not 'fixed' after a battery pull...
    Last edited by viking87; 09-15-11 at 02:52 AM.
    09-15-11 02:49 AM
  4. balenax's Avatar
    if a battery pull fixes it, even for a short time, then there's a chance it is a software issue. you could give reinstalling the os a chance, if you have the time. if you can get it replaced though, go for it better.
    09-15-11 03:04 AM
  5. mobibiz's Avatar
    I would concur with what Balenax just said about reinstalling the OS. But do wipe the device prior to a installation, using either apploader or any other third party utility.
    09-15-11 03:29 AM
  6. itzgoten's Avatar
    I have this EXACT same problem!!! Please let me know if you find a fix. X & P are tied together. B & (enter) are tied to each other. $ & (delete) are tied to each other. I just bought this phone a few days ago and only added facebook as an app. I am wondering if this is hardware or software related..

    But again. my issue is almost IDENTICAL

    I have tried pulling the battery which does not fix the issue.. alt+aA+del doesn't work because it registers as me pressing alt+aA+b&del which doesn't reset the device..
    10-03-11 06:26 PM
  7. o4liberty's Avatar
    Reload your OS I had several issues with my first device and rim told me some software was corrupt in the early release. I am on my third device but so far so good.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-03-11 08:49 PM
  8. FuzzyB's Avatar
    While I have absolutely no issues with my 9930, I will say I can no longer aA+alt+del to reset the device...and the first two weeks I actually could do this. Hmmmmm....are you guys running .254 os?

    I have this EXACT same problem!!! Please let me know if you find a fix. X & P are tied together. B & (enter) are tied to each other. $ & (delete) are tied to each other. I just bought this phone a few days ago and only added facebook as an app. I am wondering if this is hardware or software related..

    But again. my issue is almost IDENTICAL

    I have tried pulling the battery which does not fix the issue.. alt+aA+del doesn't work because it registers as me pressing alt+aA+b&del which doesn't reset the device..
    Posted from my CrackBerry at wapforums.crackberry.com
    10-03-11 08:56 PM
  9. itzgoten's Avatar
    I wiped the OS with no luck.. And this is what I'm running. I guess I'll need a new one.
    BlackBerry 9930
    smartphone (3G, CDMA, Wi-Fi)
    7.0 Bundle 1296 (v7.0.0.241, Platform 5.0.0.442)

    Posted from my CrackBerry at wapforums.crackberry.com
    10-04-11 01:53 AM
  10. pythons's Avatar
    Sprint replaced "3" phones for me because of that exact issue...
    ...I initially found out my keyboard had gone gunny-bag when I couldn't get into my password keeper.
    ...Talk about freaking out.
    11-24-11 05:18 PM
LINK TO POST COPIED TO CLIPBOARD