1. Mr.KourtanieAnderson's Avatar
    I have my messages set to 'keep forever' - i have noticed though that my messaged (specifically my texts and my facebook messages) seem to delete themseleves automatically. Any suggestions on how to stop this?
    11-15-11 10:13 AM
  2. Fret Madden's Avatar
    Is your device's application memory full? If so, it should be deleting the oldest messages to make room.
    11-15-11 12:25 PM
  3. ShoshiOne's Avatar
    I had this problem on my Torch. I had it set to "keep forever" but it would delete all messages more than a month old. I had plenty of memory, tried a battery pull, and tried to reload the os once, but it never got resolved.

    If this is happening on the 9900, I hope there is a fix to it. I'll be keeping an eye on this thread too!
    11-15-11 02:00 PM
  4. Mr.KourtanieAnderson's Avatar
    No it's not. The only apps I use are FB and Twitter so I don't download any apps from App World. I have about less than 30 emails on my phone (i usually read them, respond and then delete them)...I just deleted the extra languages support (chinese, japanese etc.) so I should have enough space.
    Yesterday i noticed nothing was happening to the texts. Tonight I scrolled back up... and yet again a few had automatically deleted.
    Do you think a OS update will fix this? Any other Verzion 9930 owners experiencing this?
    11-16-11 11:14 PM
  5. BBThemes's Avatar
    ok so the first and most important thing is are you using outlook for emails on your PC? (this may apply to other clients too).

    basically in outlook in the email setup section (forgive me for being vague, havent used outlook in aaaaages) theres an `advanced settings` box or something like that, where there is an option to `leave copy on server` as basically what happens is outlook pulls ur email down from your server. now if that box isnt checked, then when outlook pulls the email down, ur BB has its usual contact with the server and sees the email is no longer there, and then because of how your device is setup deletes the email from your device.

    so theres 2 things to do to stop this, firstly find and alter that setting in outlook so you have a copy left on your server.
    secondly (and this is easier) follow these options:
    open mail on BB> press menu key> choose `options`> select `email reconciliation`
    now here you have several options, basically determining the core variables of your issue. the key thing to have, is to set `on conflicts` to `handheld wins` as basically that means if your server and your BB are arguing over wether the email should be kept as its no longer on the server (either because you deleted it or outlooks as menitoned as above) then whats on the handset stays on the handset, if you set as `mailbox wins` then your handset will mimic whats on your email server, which is most probably what your issue is right now.

    hope that makes sense enough for ya to sort it
    11-17-11 08:32 AM
  6. Mr.KourtanieAnderson's Avatar
    Thank you I will try that for the emails. I don't use outlook so I'll try the 'easy fix' you mentioned. Any advice as far as the text messages erasing themselves?
    11-18-11 12:39 AM
LINK TO POST COPIED TO CLIPBOARD