1. aardvarkgeo's Avatar
    Hi, getting a strange issue in that I have to restart the phone for it to charge. Since I started to update my firmware, my phone will sometimes charge, and the other times, it says that it cannot charge - when I reboot, it then charges again.

    Anyone have any ideas? I generally use 3 types of chargers - the one in the box, that I use at home, and one in the office, that is from my previous BB (that I never had any trouble with charging) and sometimes the USB from the PC.

    It's frustrating me, as I never had this problem with any phone, and when I ran the stock OS, it didn't seem to have this? Should I just go back to the old OS?

    Regards,

    Wayne
    12-23-11 09:48 AM
  2. BENZ_O's Avatar
    I have the same problem. Once I installed the leak 7.1 OS, the phone charges sometimes and always have to do a battery pull when I need to charge it. I will prob load back the old OS, cuz it's annoying to battery pull on almost every charge.
    12-23-11 10:16 AM
  3. CarolClark's Avatar
    I guess you guys are not using the original charges. Blackberry phones often get this problem when we are using some third party chargers. I don't think battery charging is a software issue.
    12-23-11 11:12 AM
  4. BENZ_O's Avatar
    I am using the original charger that came in the box with my 9900.
    12-23-11 11:14 AM
  5. aardvarkgeo's Avatar
    Yes, I am using the original BB chargers too..
    12-23-11 05:12 PM
  6. mc21's Avatar
    Having this issue and have always been using the official OS. However, my dock always works. I pulled the cable from the dock and plugged into my phone and it wouldn't charge. Put cable back on dock and the phone charges through dock. So this leads me to believe that charging through the contact points can help bypass this problem.
    12-23-11 07:15 PM
  7. claykin's Avatar
    What OS version is on your phone? Do you have any apps installed? Have you tried to upgrade appworld to latest and update all installed apps?

    I'm running V7.1.0.74 and have never had a problem charging.

    Hi, getting a strange issue in that I have to restart the phone for it to charge. Since I started to update my firmware, my phone will sometimes charge, and the other times, it says that it cannot charge - when I reboot, it then charges again.

    Anyone have any ideas? I generally use 3 types of chargers - the one in the box, that I use at home, and one in the office, that is from my previous BB (that I never had any trouble with charging) and sometimes the USB from the PC.

    It's frustrating me, as I never had this problem with any phone, and when I ran the stock OS, it didn't seem to have this? Should I just go back to the old OS?

    Regards,

    Wayne
    12-23-11 07:22 PM
  8. aardvarkgeo's Avatar
    I was on the stock OS of my carrier M1 here in Singapore and it was fine. Then I got itchy fingers and updated. First to another build by M1, then to 585 and now 590. Maybe I should just go back to the original build, it was pretty good, and also didn't have the battery drop issue!
    12-23-11 07:54 PM
  9. aardvarkgeo's Avatar
    ok - was getting pretty sick of this, so I am going to go back to the original which is 261. From what I remember this build didn't have the battery drop issue, and also allowed me to charge from any charger. Let's hope this is still the case, otherwise I am going for warranty!
    12-26-11 09:38 AM
  10. aardvarkgeo's Avatar
    Just letting you know that the firmware has fixed the charging issue and also given me a much more steady battery life. I think I am going to stick with this for a while.... at least until another "official" firmware comes out!
    12-27-11 07:46 PM
LINK TO POST COPIED TO CLIPBOARD