1. vikrant.misra's Avatar
    Hi,
    Bought a bold 9900 day before. Today, suddenly it just started to show "Sim Card Error".
    i tried uploading a new OS... Didnt work... wiped the bb... nothing...
    what have i done wrong???
    BTW- It is an unlocked BB.

    Urgent help needed.

    thanks
    10-23-11 09:37 AM
  2. ibcop's Avatar
    Tried a different SIM card? Just borrow a friends and see if it works with that.

    If it's a SIM card, an OS will not help.
    10-23-11 09:44 AM
  3. vikrant.misra's Avatar
    its not with the sim card as i tried the same sim in my old bb... works fine.
    what can i do with the 9900 so my sim works on it???
    10-23-11 10:01 AM
  4. ibcop's Avatar
    its not with the sim card as i tried the same sim in my old bb... works fine.
    what can i do with the 9900 so my sim works on it???
    What carrier are you on? The 9900 is branded to what carrier?

    Where did you buy it? New/sealed?

    It may have become "blacklisted".....
    10-23-11 10:35 AM
  5. MrRJ's Avatar
    Hate to say it buddy, but I had this problem and the resolution was to replace the phone.

    Mine worked for 3 days before it just randomly started showing the error. I did a search here and came up with very little. There was one instance though were someone was using the phone with a micro sim and adapter. When removing it the adapter bent the pins out of place - not a big fix but from what I remember but not something you could do yourself.

    Hope this helps.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-23-11 01:57 PM
  6. vikrant.misra's Avatar
    Guess I'll take it to the service Centre. Hope they Gimme a new piece
    10-24-11 01:54 AM
LINK TO POST COPIED TO CLIPBOARD