1. chernenko's Avatar
    Just got my 9900 today from Tmo. For the first hour or so, everything was fine...then I noticed that the screen setting became very dim (equivalent to 50% on my 9700 when side-by-side). Autodim is off, backlight timeout 1 min, brightness 100. Tried battery pulls, what else could it be??

    Guess Ill reinstall the os. UGGGHHH - reinstalling the os the same day i get the phone. Thanks RIM! If this is a sign of things to come with this phone then I am switching to android....I cant take another super-buggy bb.

    08-31-11 07:07 PM
  2. iBerry9930's Avatar
    Complete opposite for me, even on 10% it's super bright... I would contact your provider...
    08-31-11 07:29 PM
  3. zaandam24's Avatar
    Just got my 9900 today from Tmo. For the first hour or so, everything was fine...then I noticed that the screen setting became very dim (equivalent to 50% on my 9700 when side-by-side). Autodim is off, backlight timeout 1 min, brightness 100. Tried battery pulls, what else could it be??

    Guess Ill reinstall the os. UGGGHHH - reinstalling the os the same day i get the phone. Thanks RIM! If this is a sign of things to come with this phone then I am switching to android....I cant take another super-buggy bb.

    take ur device bak and get a new 1, i noticed my 9900 was not as bright as my 1st 9900 so i got it exhanged and heres a link y its like that...

    http://forums.crackberry.com/blackbe...inside-639586/
    08-31-11 07:52 PM
  4. chernenko's Avatar
    Thanks guys...will exchange
    08-31-11 08:04 PM
  5. TheMarco's Avatar
    Indeed. My 9930 almost burns my eyes out of my sockets when it's at 100%, so bright! Definitely exchange
    08-31-11 08:09 PM
  6. jinxednuance's Avatar
    Did you consider ticking off "automatically dim backlight"? I had the same issue and thought there was a problem until I ticked it off and now my BB is as bright as ever!

    Posted from my CrackBerry at wapforums.crackberry.com
    08-31-11 10:00 PM
  7. PaulM-D's Avatar
    Yeah, one of the brightest and sharpest screens I've seen on a phone. And it is great in direct sunlight.

    Indeed. My 9930 almost burns my eyes out of my sockets when it's at 100%, so bright! Definitely exchange
    09-01-11 09:55 AM
  8. chernenko's Avatar
    Did you consider ticking off "automatically dim backlight"? I had the same issue and thought there was a problem until I ticked it off and now my BB is as bright as ever!

    Posted from my CrackBerry at wapforums.crackberry.com

    Read my original post, lol - "autodim is off"....
    09-01-11 01:25 PM
  9. jinxednuance's Avatar
    Read my original post, lol - "autodim is off"....
    lol sorry, I was at work and didn't have enough time to read it
    09-01-11 03:33 PM
  10. DannyJK's Avatar
    My Storm 1 would have a problem where when you did a battery pull and the phone rebooted the screen would be bright for a split second when the homescreen came up then it would darken to a REALLY dim brightness. And even though it said 100% brightness in settings and auto dim backlight was off It would still stay dark as ****. and **** is pretty dark unless you got the runs or somethings wrong with you.

    A second reboot usually fixed this problem. But hey it was a Storm 1 so I guess there was my problem in the first place.
    09-01-11 03:41 PM
  11. chernenko's Avatar
    Thanks for the good advice guys. I exchanged today and the new one works perfect. If anyone is having this same issue....EXCHANGE!
    09-01-11 09:44 PM
  12. jinxednuance's Avatar
    did you go back to the 10 brightness and automatically dim backlight color? if so, is it still bright then?
    09-01-11 09:58 PM
  13. anon3396357's Avatar
    BB phones definitely have one of the brightest screens around.. my eyes hurt when I pick up my 9780 in the middle of a night to read an e-mail or SMS. And brightness is set at 0 :/
    09-01-11 10:50 PM
  14. lonewolfe's Avatar
    I thought I had a problem with my screen brightness as well. I scrolled up to 10, and it barely got much brighter. Also unchecked auto dim.

    Where I made the mistake is not selecting save from the menu before I exited back to the home screen.

    Once I did that, the brightness got super bright. Guess turning off auto dim needs to be saved for the brightness to take effect.
    09-12-11 09:37 PM
LINK TO POST COPIED TO CLIPBOARD