1. ajvieni's Avatar
    Hello everyone, new member here, blackberry user since 06, just picked up a bold 9900 from at&t on thursday. i'm having some issues with this phone already...as of now it is not sending or receiving any of my sms text messages and i'm not sure why, heres the story so far.

    ordered the phone through at&t was shipped to my house on thursday, yesterday decided to turn on the phone for the first time and use it. so i went about my normal procedure that i always would of transferring phones, back up the old one plug in the new one and re add everything (btw switched from a bold 9700 to the 9900) i didn't happen to notice the little rule book in the box that at&t now sends on how to activate your phone, so i stopped my normal procedure and re did everything using the at&t way.

    All yesterday the phone received text messages and calls but would not receive any data only had 4g no big G so today i call at&t they make me turn the phone on and off a million times, verify imei and sim #'s everything checks out and they sent me a text to ensure it was working properly but still no 4G, they say the sim is bad,they authorize on my account for the store to give me a new sim and off to the at&t store i go. i get there the gentleman who works there decided to do one trick before giving me a new sim, just to remove it and he puts everything back in the phone works great, has 4G and everything, throughtout this whole day i noticed that i had texted a bunch of people and got no response so i call them and come to find they didn't receive my texts and i never received theirs....


    anyone have any ideas as to why i'm not getting any text messages? if nothing works i am going to go to the at&t store again and get a new sim just really annoyed at this point and i feel that at&t's little procedure for starting the phones up is counter productive thank you in advance for any help!
    12-05-11 10:38 PM
  2. ajvieni's Avatar
    i also thought about playing with the messaging options like the "network to send over" setting and data coding but i'm not really sure what they mean so i'm not sure if it will help
    12-05-11 10:53 PM
  3. Bonnie Bonzai's Avatar
    Hello everyone, new member here, blackberry user since 06, just picked up a bold 9900 from at&t on thursday. i'm having some issues with this phone already...as of now it is not sending or receiving any of my sms text messages and i'm not sure why, heres the story so far.

    ordered the phone through at&t was shipped to my house on thursday, yesterday decided to turn on the phone for the first time and use it. so i went about my normal procedure that i always would of transferring phones, back up the old one plug in the new one and re add everything (btw switched from a bold 9700 to the 9900) i didn't happen to notice the little rule book in the box that at&t now sends on how to activate your phone, so i stopped my normal procedure and re did everything using the at&t way.

    All yesterday the phone received text messages and calls but would not receive any data only had 4g no big G so today i call at&t they make me turn the phone on and off a million times, verify imei and sim #'s everything checks out and they sent me a text to ensure it was working properly but still no 4G, they say the sim is bad,they authorize on my account for the store to give me a new sim and off to the at&t store i go. i get there the gentleman who works there decided to do one trick before giving me a new sim, just to remove it and he puts everything back in the phone works great, has 4G and everything, throughtout this whole day i noticed that i had texted a bunch of people and got no response so i call them and come to find they didn't receive my texts and i never received theirs....


    anyone have any ideas as to why i'm not getting any text messages? if nothing works i am going to go to the at&t store again and get a new sim just really annoyed at this point and i feel that at&t's little procedure for starting the phones up is counter productive thank you in advance for any help!
    Hi there I am experiencing this with my text messages too (since last night) I ended up yanking the battery for a minute and it seems to have fixed the problem for the moment. Not sure why, with this powerful little machine we still have to resort to pulling the battery but it seems to work.
    12-05-11 11:32 PM
  4. selfishreflect's Avatar
    From my experiences:
    (Each is a step that should eventually resolve issues)

    No data issues (not due to shady signal issues) - 1. Turn mobile network off then on
    2. Switch to edge
    3. pull battery
    4. Pull battery and take and replace sim
    5. Call your carrier

    Sms issues -
    1. go to network and connections > mobile network > manual select network > select network
    2. Check your sms center
    3. Call carrier
    4. Call carrier and get a new sim

    If you are having syncing issues after using itunes match I've gotten that figured out too. Each development leads towards errors for some reason.

    Posted from my CrackBerry at wapforums.crackberry.com
    12-06-11 05:43 AM
  5. ajvieni's Avatar
    Hey bud, thanks for the suggestions unfortunately none of them worked, I am going to visit an at&t store today and get a new sim card, from what I know it should still be written on my account that I am eligible to get one, if that doesn't work I'm going to send this phone back and request another one I'm still in my 14 day period so hopefully there are no issues...any other suggestions?
    12-06-11 10:39 AM
  6. selfishreflect's Avatar
    if you can try to put the sim in another phone. if it still won't send or receive then it's the sim. i once blamed my 9900 and was yelling at my coffee mug because of it but then when it did the same on another phone then i knew it was my sim.

    so far on BB the manually select network option works for me. someone told me to try taking out the sim and replacing it again but that never worked for me.

    could be you just have a faulty sim. i've had that before too and the carrier changed it for me.

    on iPhone this happened to me every few weeks - my workaround was to reset the network settings once up to 5 times before it works. usually caused by being in a dead spot - my house - and from what i could deduce the text messages would jam up and just fail to get received in the end.

    a friend who used to work for a carrier said that sometimes the carrier would reset something without even telling you that they fixed it and voila it works. but more often than not, when all options have been exhausted, it is sometimes just simpler to replace the sim. i think i've experienced all of these scenarios.

    yes a carrier should replace your sim if it is deemed faulty with no charge.

    good luck to you.
    12-06-11 10:58 AM
  7. ajvieni's Avatar
    Yea I'm hoping its just the sim, I've tried everything else and that seems like its the only thing thay would make sense and solve it, I mean since I called at&t and told them I want a new sim I have a feeling they are cutting service to this one or something like that idk how it works exactly obviously and I doubt that's what it is but as you said, they magically switch things without telling you, I'm going to repost later on today after I get to a store and see what happens
    12-06-11 11:19 AM
  8. ajvieni's Avatar
    Ok so...update! went to the at&t store and they gave me a new sim, finally receiving texts! I didn't get any of the texts from sunday and monday so I'm assuming they are lost in the abyss the phone shortly after receiving the new sim wasn't sending texts for about 20 mins or so it kept saying this under my texts "mobile equipment status failed" but now its working ok, I also noticed that my youtube doesn't work?! I can't get any videos it says that there a problem on the site or something stupid OS
    12-06-11 11:24 PM
  9. ignites's Avatar
    From my experiences:
    (Each is a step that should eventually resolve issues)

    No data issues (not due to shady signal issues) - 1. Turn mobile network off then on
    2. Switch to edge
    3. pull battery
    4. Pull battery and take and replace sim
    5. Call your carrier

    Sms issues -
    1. go to network and connections > mobile network > manual select network > select network
    2. Check your sms center
    3. Call carrier
    4. Call carrier and get a new sim

    If you are having syncing issues after using itunes match I've gotten that figured out too. Each development leads towards errors for some reason.

    Posted from my CrackBerry at wapforums.crackberry.com
    you dont need a battery pull just hit ALT, Right Shift (aA) and DEL?
    12-07-11 12:31 AM
LINK TO POST COPIED TO CLIPBOARD