1. andy_23w's Avatar
    Hi

    Does anyone else have a BB Bold 9900, the one i got for Shannon was dropping it's network connection 2/3 times a day and needed to be rebooted to get the connection back, we replaced with a new 9900 same problem, while waiting for the new phone Shannon used the same sim in her 8250 Curve for 3 days with no issues at all she had the Curve for 3 years with no issues on the same 64k sim, same network, full city coverage ....? The 9900 was updated to the latest OS last night through Blackberry desktop manager. We have tried the options of setting the phone from 3G to 2G/3G and manually searched for network as opposed to selecting 3G only and automatic network.

    Bottom line is the phone should just work.

    Any ideas please?

    Andrew
    01-12-12 06:23 AM
  2. cooljatt18's Avatar
    try updating your OS and it could also be an issue with your carrier, try the sim in another phone too
    01-12-12 08:16 AM
  3. andy_23w's Avatar
    hi there cooljatt18 thank you for taking the time to reply, see my post re updating the phone and trying the sim in another phone.

    Does anyone think that the old sim may have a compatability issue with newer models of Blackberry, both our Curves and Pearls have used the same 64k sims with no issues at all? I have read that renewing the sim does not work.

    Supplier said the 1st handset was faulty is it possible that the replacement handset could be faulty too? or is this a common issue with other users 9900's?

    cheers
    01-12-12 08:27 AM
  4. cooljatt18's Avatar
    bold 990 has a metal band around it which i have heard hinders in signal reception, but this is the first time that i am hearing such an issue. most probably the 9900 lot which the store got from where you purchased has this issue. manufacturing defect etc. best would be to get one and check it there and then at the store for any network issues. and also there is no need to thanks buddy, we all are here to help and get helped if need be, that is all what crackberry is about.
    andy_23w likes this.
    01-12-12 03:19 PM
  5. andy_23w's Avatar
    Cheers again, I am going back to the store on Monday to get handset number 3, hopefully this one will work, the employee who is a friend of mine said one of his customers went through 5 Bold 9900s until he got one which worked properly... I'll keep you posted.
    01-13-12 06:22 AM
  6. jm1975's Avatar
    Am getting same/similar issue, and no software update seems to be available.

    Vodafone Ireland
    Device is on 7.0 1465

    Seems as though it randomly drops the network, and the only way to get it back is to force it to disable networking, and then re-enable.

    Then, it picks up a fine signal.
    01-13-12 12:12 PM
  7. andy_23w's Avatar
    Ok quick update on what is happening with our issue.

    At the weekend i took Shannons 9900 and inserted my sim into the phone which i have been using with my Pearl with zero issues for 2 years, she went back to using her Curve and experienced no problems. For two days i used the 9900 without any issues at all (please note that Network Selection was showing 'Connect Manually' and also 3G/2G, the phone did this automatically when i swapped the device, not sure if this is a factor but the more info the better?). So on Monday as planned we returned the 9900 to the dealer and received another new 9900 handset, we did this for one main reason although i experienced no problems we didn't want to be taken out of the dealers 7 day automatic returns no questions asked policy, interesting to note that this handset when started did not have the Vodacom (our network) splash screen or wallpaper like the other 3, it appears to be of different stock (this may well prove to be important) the start screen is a standard Blackberry Smartphone splash screen.

    Also on Monday Shannon went to Vodacom and received a brand new sim card (same cell number ect.)

    As of last night we 'swapped devices' form the Curve to the Bold 9900 using Blackberry Desktop Manager and inserted the new sim.

    All i can report at this point is so far so good, the phone has not dropped it's network connection but i will update in 2 or 3 days and let you know if this issue has been resolved.

    Cheers.

    Andrew
    Last edited by andy_23w; 01-17-12 at 02:32 AM.
    01-17-12 02:28 AM
  8. andy_23w's Avatar
    Maybe it is important to point out that my sim card is also on the Vodacom network the same network as Shannons.
    01-17-12 02:31 AM
  9. malyfsborin88's Avatar
    Having a similar issue on my 9900. I live in Toronto, Canada and on Rogers network. Just an hour or two ago I noticed my bbm wasn't going thru so I check my signal and it was sitting on SOS. So I turn of network and turn it back on, no use. Tried turning automatic network selection to Manual and after searching for list of network only found Bell and Telus but not Rogers. Also on a side note when I first checked network it was sitting on Telus.

    Now this is maybe the second time I've seen it happen on the same day and at first I was at home and 2nd at work. Just to let you know before hand I have excellent coverage at both places with Rogers on this and other phones.

    I'm on a hybrid of .545 and .580 which is so called the "best and most stable" of them all.

    The only thing that fixes this is a batt pull.
    01-17-12 02:51 AM
  10. cooljatt18's Avatar
    thats great, hope your problems are finished. enjoy your new bold!!
    01-17-12 10:46 AM
  11. andy_23w's Avatar
    Captains log day 2.5, still no issues with the Bold 9900 since the last update...
    cooljatt18 likes this.
    01-18-12 06:02 AM
  12. 85_305's Avatar
    I had similar issues. Updated to OS .579 and no more (or at least, very rarely) will I have that issue.
    01-18-12 11:46 AM
  13. andy_23w's Avatar
    Ok this is my finale update, in the last post 01-17-2012, 02:28 AM i explained what we did to resolve the issue, i can happily announce it worked also Shannon updated her operating system to the latest version 2 nights ago with Blackberry Desktop Manager and all is still working ok. I hope this helps others experiencing the same issue.

    Cheers

    Andrew :
    cooljatt18 likes this.
    01-20-12 03:14 AM
LINK TO POST COPIED TO CLIPBOARD