1. westhamfan's Avatar
    hi all, I've noticed that my oldest text messages are being deleted, seemingly around 30 days after receipt. Then the icon also goes green.

    Is there a setting where I can make it so that the text messages don't get deleted, unless I manually do so ? I've searched the phone & called T-Mobile, but to no avail. I would like this retained, so I know the "Last Contacted" date, so I can eventually find a way to stay in better contact with my contacts.

    Peculiarly, some messages, within an entire text message thread do get kept, so I'm really unsure why that would be. I don't recall doing anything different on those few messages.

    Anyways, if there is a setting somewhere and you know where, it would be much appreciated.

    Thanks
    Pierino
    07-03-11 09:11 AM
  2. shinematt's Avatar
    The exact same things happens to me, so i would be interested in the answer as well.

    Just so you know, i have 250mb of memory left.

    Thanks guys!

    Posted from my CrackBerry at wapforums.crackberry.com
    07-03-11 07:36 PM
  3. diegonei's Avatar
    Here:

    Messages > Menu > Options > Messages Display and Actions (scroll to the bottom).

    I'd advise against setting all messages for forever-keeping. Rather you use Menu > Archive the ones you really want to keep, because after sometime (not now, not tomorrow) all those stored messages will bog down your 9780's performance.

    Myself, I set it at 15 days.

    EDIT: I must add that since the Gmail Plugin, I find myself deleting emails as soon as I act on them (provided I am sure I will not need to wait for a reply within that same week) and then searching for the messages if I ever need them again. Of course, right now, this only works on BIS/Gmail or BES/Work accounts.
    Last edited by diegonei; 07-03-11 at 11:23 PM.
    07-03-11 08:30 PM
  4. agough05's Avatar
    I had originally set it to keep messages forever on my 9650 Tour when I had it. I didn't really think much of it becuase I had 150MB or so of free space. Then, when I got to around 1000 unread emails (spam control used to be a problem for me) the phone started to get noticeably slower, not to mention backups took 15 minutes. Definitely don't keep everything forever if you don't have to. I keep them for thew standard 30 days on my 9780 now.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-03-11 10:05 PM
  5. westhamfan's Avatar
    Nice one diegonei, I was actually in the bank today, and wanted to make a payment, the details were on a deleted email, but the bank man managed to track it down and was done, it's just things like that that's just a bit nerve wracking, will keep an eye on the speed, but do prefer to keep a bit longer. I figure this means that setting applies to Emails, Blackberry Messenger & Text Messages. Now the T-Mobile person I spoke to didn't know this.

    Cheers
    Pierino
    07-04-11 07:51 PM
  6. diegonei's Avatar
    I also have my device set only to delete things on the handheld. This way I can keep the device clean without really losing anything.
    07-04-11 09:05 PM
  7. melbas's Avatar
    Here:

    Messages > Menu > Options > Messages Display and Actions (scroll to the bottom).

    I'd advise against setting all messages for forever-keeping. Rather you use Menu > Archive the ones you really want to keep, because after sometime (not now, not tomorrow) all those stored messages will bog down your 9780's performance.

    Myself, I set it at 15 days.

    EDIT: I must add that since the Gmail Plugin, I find myself deleting emails as soon as I act on them (provided I am sure I will not need to wait for a reply within that same week) and then searching for the messages if I ever need them again. Of course, right now, this only works on BIS/Gmail or BES/Work accounts.
    I've tried to do what you've adviced, but I couldn't get the Messages > Menu > Options > Messages Display and Actions (scroll to the bottom). What I have are General Text
    Messaging Options, SMS, MMS. There is no Messages Display and Actions. The old text messages just disappear and I Desperately need them back. Please help! Thank you!
    By the way I'm using Bold 9780 v6.0.0.448
    03-20-12 08:21 PM
  8. HiroCrackberry's Avatar
    @melbas: You need to open up the option of your "email" message and not "sms". then you can surely find the steps mentioned by @diegonei. Good Luck!
    03-21-12 11:39 PM
  9. melbas's Avatar
    @melbas: You need to open up the option of your "email" message and not "sms". then you can surely find the steps mentioned by @diegonei. Good Luck!
    oh! lol I got it now. Thank you!!
    03-21-12 11:42 PM
  10. yogeshsahni's Avatar
    losing sms after 15 days, wanting them to stay till i delete; what do i need to do ? also the "spanner" icon on the menu is not showing up ?? HELP
    11-30-13 08:34 AM
  11. BBerryPowerUser's Avatar
    Look up about 10 posts in this thread, the instructions are there for you on how to hold text messages longer.

    I also will add, I much prefer the 3rd party app "Crunch SMS". It is a highly customizable texting app written very well and more iPhone-esque in appearance. I'm not a big fan of iPhone, but have always thought their SMS application was one of the very finest.
    12-06-13 05:10 PM
LINK TO POST COPIED TO CLIPBOARD
We have updated our Privacy Policy and Terms & Conditions. Please check them out.