1. matteds's Avatar
    Hi. I've been working on a theme for about 4 hours. I finally started using Composer a little bit in my personal stuff and have noticed that whatever comes out of composer seems to lose quality when it's actually running on the device.

    I've got two pictures to help express what I'm saying. The first is a screensnap, the second is a print screen of theme builder. Can anyone help me get the device looking as good as the theme builder preview?

    Thanks!


    Although it doesn't look too bad, the manage connections and clock icon (and "Programs") highlights are lower quality, more jagged, and the "Programs" text along with home-made blackberry symbol look like someone gave 'em the one-two punch. Please mind you that the image has jpeg compression, but the "PROGRAMS" text and BB symbol actually look exactly like that.

    The second is a link cause it's a large image (like 1360x768 or something like that)

    http://a.imageshack.us/img59/2944/ahhn.png

    If anyone's actually interested in the theme itself, then I can google how to host an OTA download and share it with whoever's interested. The wallpaper is the original HTC Desire wallpaper.
    Last edited by matteds; 07-13-10 at 11:08 PM.
    07-13-10 11:02 PM
  2. hastings's Avatar
    This should be posted in the Theme Developer's Forum. Hopefully a moderator will move it.

    While I don't know for sure what could cause the problem, I have two theories:

    1) You may have added the "PROGRAMS" text as a graphic file and scaled it up or down using Composer. Make sure both scale dimensions are set at 100%, or the full resolution of the image you're adding. The device does a poor job at scaling raster graphics as it does not apply any antialiasing, even on a transparent PNG.

    2) If the "PROGRAMS" text is a raster graphic (PNG image) and you're adding it from within Composer, that means when you export the SVG you're depending on the application to compress the image using whatever settings you've selected. A better way is to just grab the code, skipping all the exporting. In Composer, on the top menu, press File -> "View SVG" (or just the ctrl+n shortcut), that will open up the Notepad application with the code ready to go. From there, just save that text file as an .SVG and modify the code so that the "PROGRAMS" image is linking to the correct directory, usually yourSVG.svg/images/yourimage.png.

    This has the advantage of using your original source image, which presumably, is the best quality.

    Good luck!
    07-13-10 11:59 PM
  3. matteds's Avatar
    My bad. I didn't see a theme dev forum. I've properly scaled everything to 100%. I'm looking at the .svg in notepad, I grabbed the directory and checked the image being used in the .svg. Same exact image, but what I don't understand is that the original is about 8KB, the one used in Composer in the Images folder is 50KB, but they're the same exact image. I'll try replace the composer-generated one and switch to the original and report back.
    07-14-10 12:13 AM
  4. matteds's Avatar
    Correction, in Composer the image was scaled down about 20 pixels, which is odd cause when it was first imported it was a proper 200x64. Interesting, this'll hopefully fix it.

    Edit: Well that didn't fix it, but replacing the images generated by Composer with the originals sure did. Thanks broseph.
    Last edited by matteds; 07-14-10 at 12:21 AM.
    07-14-10 12:17 AM
  5. hastings's Avatar
    Good to hear. Using the originals is always the best course of action, Photoshop is much better for image exports than Composer. (=

    Cheers!
    07-14-10 12:24 AM
  6. QBall45's Avatar
    For your ota hosting needs check out MyBBOTA.com

    Posted from my CrackBerry at wapforums.crackberry.com
    07-14-10 08:44 AM
LINK TO POST COPIED TO CLIPBOARD