1. JayBern's Avatar
    ht tp://na. blackberry. com/ eng/ developers/ themes/ devtools .jsp

    I am very interested in creating themes for everyone because I personally find it hard to find themes that I want. Particular stuff here and there that I want.

    Sooo, if you guys would please guide me with my understanding.

    Plazmic Content Developers Kit v4.7
    With the Plazmic Content Developers Kit v4.7, you can create themes for the BlackBerry Storm smartphone, BlackBerry Curve 8900 smartphone and BlackBerry Curve 8350i smartphone.

    When you install the Plazmic Content Developers Kit v4.7 Update Patch, youll also be able to create themes for the BlackBerry Tour 9630 smartphone and BlackBerry Curve 8520 smartphone.

    Compatibility
    The Plazmic Content Developer's Kit v4.7 is compatible with BlackBerry Device Software v4.7.

    Note: Themes created in the Plazmic Theme Builder are only supported on BlackBerry smartphones running BlackBerry Device Software v4.2 or higher.
    So you can see BlackBerry Bold isn't in the list stated in the first paragraph in the quote above taken from the site.

    Then they went on to say this CDK v4.7 is compatible with BB Device software 4.7. Which means the CDK v4.7 is meant for the 4.7 devices only?

    So I would have to download the CDK v4.6 to create themes for the Bold 9000 since the Bold 9000 runs on 4.6 right?

    You could leave behind what kind of themes you are looking for too. I'd be more than happy to create one specifically for you guys. (:
    09-08-09 07:38 AM
  2. maxiang's Avatar
    Plazmic 4.7 covers the Bold as well Remember to download device simulators for all the Berry's you plan on making themes for. That way you can test them before you send them out into the world You will also need an image editing program that can handle .png and transparent images, ie Photoshop or GIMP. After you install plazmic check out the sample folder as well.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-08-09 08:01 AM
  3. JayBern's Avatar
    For the Bold 9000, I'd have to download the "BlackBerry Device Simulators v4.6.0?

    Is there like a list of all the phone's versions?
    09-08-09 08:20 AM
  4. JasW's Avatar
    A list of all the phone's versions? Not really. Device Simulators v4.6.0 will let you see what the theme you design will look like on any 4.6.0.xxx OS. Some themes work on 5.0.0.xxx OSes, some apparently don't.
    09-08-09 08:44 AM
  5. JayBern's Avatar
    Is it safe to say that the versions are "assigned" to the phones? Like the storm runs on 4.7 and the bold runs on 4.6?

    I heard. 4.7 is for bb touch phones.

    Sorry I'm new to the developer's world. Please enlighten me!

    Posted from my CrackBerry at wapforums.crackberry.com
    09-08-09 08:52 AM
  6. fabuloso's Avatar
    The only problem I seem to can't understand is why some systems get the Runtime Error pop ups when trying to change certain images or backgrounds in themes.

    4.6 is giving me this problem now. I am going to upgrade to 4.7 maybe it fixes that.
    09-08-09 09:29 AM
LINK TO POST COPIED TO CLIPBOARD